PDA

View Full Version : question about css style sheets


djbutter22
10-14-2009, 03:29 PM
Hi,
how do I get the style.css to link to the page without it assigning a drive location to it? I don't really know how to word it so here is what I'm talking about:
I want this background-image: url(images/nav-red-bar.png);

instead of this

background-image: url(file:///E|/cylakes/images/nav-red-bar.png);

Is it because the style sheet,index page and images aren't in the same root folder?

domedia
10-14-2009, 04:25 PM
This is almost always an issue of not taking the time to define a site properly before starting to work on it.

djbutter22
10-14-2009, 04:32 PM
yeah I think so. I already have a site but I'm trying to build a new one while the old one is still up.

domedia
10-14-2009, 04:34 PM
ok, so once your site definitions are right, the links should be fixed.

djbutter22
10-14-2009, 04:37 PM
My problem is, I'm working on it with 2 different computers and an external HD. WHen i plug it into my laptop, it calls the HD drive F, and on my desktop its drive E. When I define my root folder, it attaches the drive's letter with it. The same goes with the style sheet, it is assigned to the E or F drive and when i try to open it on a different computer it won't attach the style to the page

DWcourse
10-14-2009, 09:12 PM
So you just need to define the local site correctly for each computer.

djbutter22
10-14-2009, 09:17 PM
oh ok thanks, I did not know you had to do that for each computer. Whew!! I'm glad its that simple