PDA

View Full Version : Gap between content and footer, after using Spry validation


fs_tigre
09-10-2009, 02:24 PM
Hi,

I know, I know its me again...

Last night was trying to validate my first contact form using the Spry validation in Dreamweaver CS4, the problem is that after adding a couple of fields my footer started moving down, so I end up with a big gap between my content and the footer. There is a lot of room between the footer and the added fields in other words the fields should fit just fine.

Is this because the code added (invisible code) with the Spry validation (its making it grow)?

How can I prevent this from moving?

Oh, page looks fine (no gap) when preview in Safari, Firefox and Opera.

Thanks

domedia
09-11-2009, 02:49 AM
Please provide a link.

fs_tigre
09-13-2009, 12:39 PM
First of all thank you for your replay!

Here are two of my pages where the same problem exists. Again, there is no gap when viewed on a browser (works on all browsers) only in Dreamweaver.

On this (http://www.victorandjoesremodeling.com/slideShow.html) page the gap started appearing when I inserted the photo slide show (swf file)

On this one (http://www.victorandjoesremodeling.com/contactUs.html) the gap started when I inserted the Spry validation to the form.

I can make the page a lot bigger than the actual content but the gap will still show.

Thanks

domedia
09-13-2009, 07:19 PM
If the issue is only in DW's renderer, you're fine.
Noone is going to use DW to view your site so it's s non issue. During development, always test your site in browsers, not in DW's design view.
DW is using Webkit for it's renderer, which is the same as Safari is using.

fs_tigre
09-13-2009, 08:45 PM
Have you seen this before? So there is no fix for this (I would like to know whats causing it)?