PDA

View Full Version : dreamweaver CS4 with snow leopard problems


mdscarpa
09-02-2009, 02:36 PM
Surprised no one else has started a thread like this... I know there are issues with the menus docking and with it crashing on occasion, those are somewhat managable problems. My problem is my sites wont sync with their servers and if I open a local copy of a page and edit it it will not save even locally, I get some error about file not found even though the file is clearly there. When i try to upload or download a page to or from the server I get FTP access denied. I have deleted my preferences and site files multiple times, reinstalled all to no avail. I have a macbook air and it worked perfect in leopard. I did a clean install of SL and a full install of CS4, no upgrades. I double checked my settings multiple times and even added the site on my macbook with tiger and it worked like a charm first time. Hopefully enough people have this problem to have it resolved soon.

sbaker
09-02-2009, 05:49 PM
I was on the Illustrator and Flash forums and there is a thread on those with the same question. It seems there are problems and it was suggested, on one of those forums, that you wait three to six months after Apple intros a new OS before you load it. Thereby letting others do the R&D. Makes sense to me, OS 10.5 is working fine on my machine currently.

Ricky55
09-02-2009, 07:19 PM
I'm running Dreamweaver under 10.6 and it seems fine so far. I've had a few issues with file permissions don't know if thats effecting you.

Also, with regards to FTP I always use the IP address of the server rather than the text version.

This isn't down to waiting for Apple to fix its probably more a case of a Adobe. According to Adobe though the most up to date version of CS4 should run fine under 10.6. Have you updated CS4?

I don't agree with the last user, I'm using 10.6 for my main works machine, its a beautiful OS and if we didn't bite the bullet we'd still be using OS9.

Have you ever looked at using an alternative to Dreamweaver? If you code by hand Coda is excellent from Panic and this works fine under 10.6.

mdscarpa
09-05-2009, 07:14 PM
It seems like most of my problem is permission related because I constantly get messages saying the file isnt there when it actually is or that dreamweaver cannot access the file..

It connects to the FTP fine, maybe it is having trouble writing them on the local end? I use the IP of the FTP in my settings as well.

I have been checking daily for updates because I am stuck using my old macbook for my dreamweaver needs. Im not a professional developer, but I am starting another business and am trying to get my site up and running as soon as possible so learning a new program and coding the whole thing are not really an option for me.

I am not using file vault and I really could not think of how else to resolve a permissions issue. What did you do to resolve it and where can I adjust file permissions?

DWcourse
09-05-2009, 11:30 PM
Exactly what can't you do?

If you can't open a local file, edit and save it, it's probably a local permissions problem.

If you can connect to the site and see the correct files in the remote view but can't download them, it's probably a server issue.

If you connect to the server but see strange files on the remote site then you probably need to fix the setting for Host Directory in your Remote Site setup.

Also, you might want to try downloading a free ftp program and seeing if you can connect/download with that.

mdscarpa
09-06-2009, 06:18 PM
well i doubt its a server issue because it works on my other mac with the same user and info. i even logged in as root user and tried to see if it would work that way but it did not. i connected to my ftp in dreamweaver and went to local view, control clicked and went to set permissions. All my boxes were unchecked, so i set the permissions to 774 clicked ok. Same error. I went back in and decided I would check everything and see if that worked. When i went back in everything was unchecked again. Looks like my dreamweaver is having trouble saving preferences?? I dont understand how it is a fresh install of snow leopard and CS4 and I have not altered any computer settings...

Ricky55
09-06-2009, 07:25 PM
Just try moving the file in question using the Finder, by dragging from one folder to another. If the file won't move and tries to copy you know its set to read only.

If this is the case get info on the folder and change the permissions. For me that didn't even work though.

If it doesn't for you try using the Disk Utility Repair Permissions.

This still didn't work for me.

I even called Apple and they had no idea.

In the end I zipped the folder in question and uncompressed to a different location. Then replaced the original folder with the one that had been uncompressed. Zipping and unzipping resets fille permissions.

HTH

Thanks

Ricky55

Ricky55
09-06-2009, 07:27 PM
You could also try deleting the file Menlo, this has been reported as casuing issues. This is a new font to 10.6

One of my iMacs is a 2.4Ghz DD2 system and this runs CS4 like a charm, my other iMac is a 3.0Ghz machine with DD3 and this is still a little buggy.

DWcourse
09-06-2009, 11:16 PM
did you try resetting the permission in the Finder (using Get Info)?

mdscarpa
09-07-2009, 02:00 AM
I just keep getting more and more aggravated... ive tried many different locations for my local folder.. even created a new folder directly under my harddrive with no files in it with the intention of downloading the files off the server. My mac permissions are set for everyone to read and write so I could rule that out. I deleted the menlo font.. it has to be something with the coding of dreamweaver or SL. Somtimes when i go to manage my site the local folder path is completely different then the way i left it sometimes having /harddrive/harddrive right next to each other and pointing to a location i cannot find... then sometimes it points to the correct path but when i click on the folder to browse the path it pulls up a completely different path that it says in the box... its just crazy, ive spent hours and have simplified everything i can in order to rule things out... ive tried multiple sites, different logins, both of which work on my macbook with tiger. the only other thing i can think of is completely removing dreamweaver... i deleted all the plist and preference files as well as the sites folder then went to reinstall... only thing i can think of is trying to use this: http://www.adobe.com/support/contact/cs4clean.html and reinstall the entire suite which is a huge pain but at this point its seems to be the only choice left... trying it now

mdscarpa
09-07-2009, 04:52 AM
well its like 3 hours later and i finally got it installed and ran all the updates... same issue... i have some ridiculous path that got changed automatically... /Hard Drive/Hard Drive/Hard Drive/Users/mdscarpa/Documents/CTIT for some reasons there are layers of folders called Hard Drive that keep appearing under my actually Hard Drive ... theres more then the ones that are in that path... i dont understand how it could be this messed up, i change the local path and go back in to verify it changed and it has something ridiculous like this in it