PDA

View Full Version : can't find blue spry menu bar tab!


toto1004
08-07-2009, 09:55 PM
After I create a spry menu bar, and save it, when I go back into the webpage and try to edit the menu bar to add and subtract different items the blue tab is no where to be found!

At first I thought I had entered something wrong, so I deleted the whole menu bar and started over. Nope! Same thing happened again! The only way I could get the blue tab to appear was to create a 2nd menu bar, then I did my editing and deleted the dummy 2nd menu bar. I could not find anyone else on google with this problem so I was hoping somewhere here would be able to help me. :confused:

toto1004
08-12-2009, 06:07 PM
this is so bizarre! when I mouseover the menu bar with the Items it highlights them, but no blue tab pops up...it's been 6 days and I'm still trying to figure it out. Has anyone else had that problem?

DWcourse
08-12-2009, 07:11 PM
without a page to look at it's not very clear what you're asking.

toto1004
08-12-2009, 07:21 PM
Sorry about that! :lol: here you go. Here's little blue tab in the picture that is giving me problems. It's supposed to pop up when you mouseover to edit the Menu Bar but it doesn't for me once I've saved and exited away from the page.

DWcourse
08-12-2009, 08:30 PM
Sorry about that! :lol: here you go. Here's little blue tab in the picture that is giving me problems. It's supposed to pop up when you mouseover to edit the Menu Bar but it doesn't for me once I've saved and exited away from the page.

That's just a "helper" that Dreamweaver shows when certain items (in this case your Spry menubar are selected. It 's not actually part of the page and won't appear in the browser. To select the menubar and get the blue tab to show:


Select within the menubar
Click on the <ul> tag (in this case <ul.MenuBarHorizontal#MenuBar1>) in the tag list in the status bar at the bottom of the Document window.

toto1004
08-12-2009, 08:47 PM
When I just clicked on the <ul> tag at the bottom of the window only the code was highlighted at the top, but the the blue tab didn't pop up. Also the properties did not change to the menu bar properties that allows me to edit the Items.

toto1004
08-12-2009, 08:52 PM
here's the before and after picture

DWcourse
08-12-2009, 09:53 PM
Very weird, I just discovered the same thing on one of my pages with a vertical menu.

A couple questions:

Mac or PC?
CS3 or CS4?
Did you externalize you javascripts at some point?

toto1004
08-12-2009, 10:06 PM
PC, CS3, nope, didn't externalize any javascripts! ;-)

DWcourse
08-12-2009, 10:21 PM
Mac, CS4 and did.

Anyway all I was able to do was reinsert the menu.

toto1004
08-12-2009, 10:51 PM
I know me too! Or else I make a new one somewhere on the page, and that somehow activates the blue tab in my original menu to start working again. Maybe it's a bug?

DWcourse
08-12-2009, 11:21 PM
Maybe it's a bug?

I'd say it's a big, fat cockroach!

And BTW, inserting a second menu worked for me as well except I had to rename the original menu MenuBar2 to get that to work!

toto1004
08-13-2009, 03:56 PM
a big fat nasty cockroach!! :mrgreen: Anyways, thanks for looking into the issue for me!

LaserSailor
01-31-2010, 09:42 PM
I was able to fix this by going to the html code and making a change in the text for one of the menu items. Once I did that, the blue selection tab on the spry horizontal menu bar showed up.:)