PDA

View Full Version : Embedded SWF Problem


blimp
07-31-2009, 05:22 AM
I embedded a SWF on a page and have checked it in Dreamweaver by selecting FILE | PREVIEW IN BROWSER. The page works just fine, video plays back and rollover button works perfect.

I've then uploaded the SWF,FLV,html page and scripts to my server and when tested, the video wouldn't play.


Below are some snapshots, the code and the html link to see if someone can give me a hand on this one.....:confused:



This is a snapshot of the files on my server:

http://img394.imageshack.us/img394/6344/picture2ihe.png

Snapshot of the files on my desktop:

http://img338.imageshack.us/img338/5946/picture3x.png

The page that's not working LIVE (http://blimpmedia.com.au/toniandguy/)

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<title>Toni and Guy Hairdressing</title>
<style>
html, body {
height: 100%;
margin: 0;
padding: 0;
background-color:#000
}
* {
margin:0px auto;
padding:0;
}
div#main_container {
visibility: hidden;
width: 100%;
height: 50%;
margin-top: -225px;
float: left;
}
div#wrapper {
width: 800px;
height: 450px;
clear: both;
background: #000;
position: relative;
top: -225px;
/* IE4ever Hack: Hide from IE4 **/
position: static;
border: 1px solid #333;/** end hack */
}
/* Hide from IE5mac \*//*/
div#main_container {
display: none;
}
html, body {
height: auto;
}
/* end hack */
/* ]]> */
#animation {
height: 450px;
width: 800px;
}
#link_button {
width:134px;
height:27px;
margin:10px auto;
}
</style>
<script src="Scripts/swfobject_modified.js" type="text/javascript"></script>
<script type="text/javascript">
<!--
function MM_swapImgRestore() { //v3.0
var i,x,a=document.MM_sr; for(i=0;a&&i<a.length&&(x=a[i])&&x.oSrc;i++) x.src=x.oSrc;
}
function MM_preloadImages() { //v3.0
var d=document; if(d.images){ if(!d.MM_p) d.MM_p=new Array();
var i,j=d.MM_p.length,a=MM_preloadImages.arguments; for(i=0; i<a.length; i++)
if (a[i].indexOf("#")!=0){ d.MM_p[j]=new Image; d.MM_p[j++].src=a[i];}}
}

function MM_findObj(n, d) { //v4.01
var p,i,x; if(!d) d=document; if((p=n.indexOf("?"))>0&&parent.frames.length) {
d=parent.frames[n.substring(p+1)].document; n=n.substring(0,p);}
if(!(x=d[n])&&d.all) x=d.all[n]; for (i=0;!x&&i<d.forms.length;i++) x=d.forms[i][n];
for(i=0;!x&&d.layers&&i<d.layers.length;i++) x=MM_findObj(n,d.layers[i].document);
if(!x && d.getElementById) x=d.getElementById(n); return x;
}

function MM_swapImage() { //v3.0
var i,j=0,x,a=MM_swapImage.arguments; document.MM_sr=new Array; for(i=0;i<(a.length-2);i+=3)
if ((x=MM_findObj(a[i]))!=null){document.MM_sr[j++]=x; if(!x.oSrc) x.oSrc=x.src; x.src=a[i+2];}
}
//-->
</script>
</head>

<body onload="MM_preloadImages('enter_a_hover.gif')">
<div id="main_container"></div>
<div id="wrapper">
<div id="animation">
<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" width="800" height="450" id="FlashID" title="Toni and Guy">
<param name="movie" value="toniandguyintro.swf" />
<param name="quality" value="high" />
<param name="wmode" value="opaque" />
<param name="swfversion" value="6.0.65.0" />
<!-- This param tag prompts users with Flash Player 6.0 r65 and higher to download the latest version of Flash Player. Delete it if you donít want users to see the prompt. -->
<param name="expressinstall" value="Scripts/expressInstall.swf" />
<param name="LOOP" value="false" />
<!-- Next object tag is for non-IE browsers. So hide it from IE using IECC. -->
<!--[if !IE]>-->
<object type="application/x-shockwave-flash" data="toniandguyintro.swf" width="800" height="450">
<!--<![endif]-->
<param name="quality" value="high" />
<param name="wmode" value="opaque" />
<param name="swfversion" value="6.0.65.0" />
<param name="expressinstall" value="Scripts/expressInstall.swf" />
<param name="LOOP" value="false" />
<!-- The browser displays the following alternative content for users with Flash Player 6.0 and older. -->
<div>
<h4>Content on this page requires a newer version of Adobe Flash Player.</h4>
<p><a href="http://www.adobe.com/go/getflashplayer"><img src="http://www.adobe.com/images/shared/download_buttons/get_flash_player.gif" alt="Get Adobe Flash player" width="112" height="33" /></a></p>
</div>
<!--[if !IE]>-->
</object>
<!--<![endif]-->
</object>
</div>
<div id="link_button"><a href="http://toniandguyi.com.au/" onmouseout="MM_swapImgRestore()" onmouseover="MM_swapImage('Enter Site','','enter_a_hover.gif',1)"><img src="enter_a.gif" alt="Toni and Guy Enter Site" name="Enter Site" width="134" height="27" border="0" id="Enter Site" /></a></div>
</div>
<script type="text/javascript">
<!--
swfobject.registerObject("FlashID");
//-->
</script>
</body>
</html>

blimp
07-31-2009, 05:51 AM
Not sure if this will help, I've created a new page in Dreamweaver and selected insert | media | SWF. So ths page has no CSS no other div other than the html and SWF.

click here to see the link (http://blimpmedia.com.au/toniandguy/untitled.html)

DWcourse
07-31-2009, 03:49 PM
In the code where you inserted the flash you have:

toni&amp;guyintro.swf

But the actual file name is tonyandguyintro.swf