PDA

View Full Version : Template Destroys Links


JohnnieG
06-01-2009, 05:22 PM
I manage a very large web site www.murraygreybeefcattle.com (http://www.murraygreybeefcattle.com). I did the Original site in Dreamweaver MX, but have had to "upgrade" to CS3. This site is very large and I would love to use the Template feature, but everytime I try, the Template destroys the links by pointing the browser toward the "Templates" folder.

This happened in MX and again in CS3.

How to correct this? Any help is greatly appreciated.

DWcourse
06-01-2009, 07:59 PM
How did you try to create the template?

JohnnieG
06-01-2009, 08:06 PM
New > template
added Firework HTML object banner w/drop down menu
added Firework HTML objects nav roll over buttons right side
put in editable region
saved as template

reopened template saved as index.htm
added content, saved page as htm
uploaded and DW added "/Templates/" to the url of every link in the drop down menu

www.murraygreybeefcattle.com (http://www.murraygreybeefcattle.com) click on "Forms" > "printable forms" > any one and you will see the error

DWcourse
06-01-2009, 09:30 PM
When you save a template. It is stored in the Templates folder (with a .dwt extension). To create a new page from a template DO NOT OPEN THE TEMPLATE instead:

Select menu File>New
In the New Document dialog:
Select "Page from Template" in the category list at left
Select your template from the "Template(s) for the Site "your site"" list.
Click the create button.Then edit the file and save it as usual.

NOTE: When you create a template, it must have at least one Editable Region defined for you to be able to edit your new page.

JohnnieG
06-01-2009, 11:04 PM
DW - Let me try that!! Sounds good to me. I have not done it this way.

JohnnieG
06-01-2009, 11:36 PM
DW - I followed your directions and I must have done something wrong!!

http://www.murraygreybeefcattle.com/TestPage.htm

Thanks
file:///C:/Users/John/AppData/Local/Temp/moz-screenshot.jpgfile:///C:/Users/John/AppData/Local/Temp/moz-screenshot-1.jpg

DWcourse
06-02-2009, 02:22 AM
Actually it seems to be fine except for the fact that you created an ASP Javacsript template rather than an html one.

That accounts for the line:
<%@LANGUAGE="JAVASCRIPT" CODEPAGE="65001"%>
At the beginning of your page.

To create a new template from scratch.
menu File>New…
choose Blank Template as the category
Choose HTML Template as the Template Type
Choose none (or your preferred layout) in Layout.To create a template from an existing html page choose: menu File>Save as Template…

BTW, the [IMG] link you included points to a file on your computer. It doesn't do the rest of us much good.

JohnnieG
06-02-2009, 12:25 PM
DWCourse - Thanks a lot, it looks better. The menu worked properly.

http://www.murraygreybeefcattle.com/TestPage.html

However, when I open this page in Firefox from the file on my computer, all I get is the list of underlined links that are built into the Banner Image as Fireworks drop down menu.

When I open the file on my computer in IE7, I get the "missing images" outlines and the list of list of underlined links. Does this html file require server side support?

Many thanks.

DWcourse
06-02-2009, 02:21 PM
Looks fine online. Do you have your local site defined properly?

Here's how: http://www.dreamweaverclub.com/define-your-site.php (http://www.dreamweaverclub.com/forum/../define-your-site.php)