PDA

View Full Version : internet explorer 6 ignoring my margin-bottom: 25px on wrapper


silverglade
05-28-2009, 08:40 PM
hi, on most of my sites id like to now add a margin on the bottom of my wrapper so the background shows through. an example page where IE6 ignores my margin: 50px auto 25px auto; is below. any help greatly appreciated. derek

http://derekvanderven.com/liberty_co/index.html


here is the css

@charset "utf-8";
/* CSS Document */


body {
margin: 0;
padding: 0;
}
#wrapper {
overflow: auto;
width: 900px;
height: 629px;
margin: 0 auto 0 auto;
background-image: url(images_raw/final_liberty_background.jpg);
background-repeat:no-repeat;
border: solid black 2px;
}

#nav_links {
width: 448px;
float: right;
margin-top: 125px;
margin-right: 10px;
margin-bottom: 0;
margin-left: auto;
}
#nav_links img {
float: left;
}
and here is the html for the page

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<!--[if lt IE 7]>
<link href="iefixes.css" rel="stylesheet" type="text/css" /> <![endif]-->
<link href="liberty.css" rel="stylesheet" type="text/css"/>
<title>Liberty Company Home</title>

<style type="text/css">
<!--
body {
background-image: url(pattern_145_light.gif);
background-repeat: repeat;
}
-->
</style></head>

<body>

<div id="wrapper"><div id="nav_links"><img src="images_raw/off_nav_slices/home.jpg" width="103" height="45" border="0" usemap="#Map" />
<map name="Map" id="Map"><area shape="rect" coords="8,6,94,38" href="index.html" />
</map><img src="images_raw/off_nav_slices/about.jpg" width="99" height="45" border="0" usemap="#Map2" />
<map name="Map2" id="Map2"><area shape="rect" coords="10,9,91,38" href="about.html" alt="about" />
</map><img src="images_raw/off_nav_slices/links.jpg" width="107" height="45" border="0" usemap="#Map3" />
<map name="Map3" id="Map3"><area shape="rect" coords="19,7,100,35" href="links.html" alt="links" />
</map><img src="images_raw/off_nav_slices/contact.jpg" width="134" height="45" border="0" usemap="#Map4" />
<map name="Map4" id="Map4"><area shape="rect" coords="20,9,117,35" href="contact.html" alt="contact" />
</map></div>
</div>
</body>
</html>

coloeagle
05-28-2009, 08:50 PM
Your "iefixes.css" file can't be found. Insure you have uploaded it.

silverglade
05-28-2009, 08:51 PM
ok i added margin bottom: 20px and it made the space at bottom in ie6. is that the right fix? derekhttp://www.webmaster-talk.com/images/smilies/biggrin.gif

i added the wrong link i fixed it above. also i did just upload iefixes. thanks. derek

coloeagle
05-28-2009, 09:10 PM
Should do it. If everything displays as intended then the fix is correct.

silverglade
05-29-2009, 10:59 AM
great thank you coloeagle. :-D:-D