View Full Version : Dynamic Dropdown Problem

04-30-2009, 11:16 AM
Dear David,

Many thanks for your time and effort presenting these great video tutorials, much appreciated.:-D

I have downloaded your tutorial code for the dynamic dropdown video, worked through it step by step and when I preview in a browser I get this at the top of the browser page...

Notice: Undefined index: make in G:\wamp\www\mysite\dropdown.php on line 4

Also, the first dropdown (Car make) works fine with the list populated but the second dropdown (Car Model) has this error message in the dropdown menu....

Notice: Undefined variable: rowModel in G:\wamp\www\mysite\dropdown.php on line 39

I have found that in your previous videos - I continue to get these "Undefined variable" messages, although, after disabling the error messages, the code works but not in this dropdown video as the second dropdown box menu has the above error always.

I have also used your sql file to populate the database "dwc" and everything connects to it. It's just these "undefined" errors that are causing the problems when live previewing.

I am using the new wamp2 with bundles - php 5.2.9-2, mysql 5.1.33 and apache 2.2.11

I am also using EMS SQL Manager 2007.

Dreamweaver CS4.

Do you think there is something written into the newer SQL or PHP bundle that causes these errors?

Thanks again,


04-30-2009, 03:09 PM

When I add this code....

// Turn off all error reporting

directly under the require_once("Connections/connection.php"); // database connection......everything works fine.

Turning off the error reporting isn't a good idea but this makes everything work. So why is it after I do exactly as instructed in the videos am I getting the Errors?

Must be something causing it in the new WAMP2 bundle perhaps??

-NairB :confused:

04-30-2009, 04:38 PM
your error settings in your PHP.ini file is too sensitive

open your PHP.ini file

scroll down to the error handling section and uncomment or add this

error_reporting = E_ALL & ~E_NOTICE

remember to prefix all other error_reporting settings with a ; to turn that off

05-01-2009, 01:38 AM
BRILLIANT David thankyou.....that worked. Here is what my php.ini file error section now looks like....changes in red....

; Examples:
; - Show all errors, except for notices and coding standards warnings
error_reporting = E_ALL & ~E_NOTICE
; - Show all errors, except for notices
;error_reporting = E_ALL & ~E_NOTICE | E_STRICT
; - Show only errors
; - Show all errors, except coding standards warnings
;error_reporting = E_ALL

I would like to add that after you change the error config and save the php.ini file, make sure you "Restart all Services" engine in the WAMP icon to refresh these changes or it will have no effect.

Thanks again David for you help.

ps...any more vids coming soon from the toon lol ???

A happy NairB :D

05-01-2009, 06:30 AM
you have the lot

im doing 1-2-1 training now