PDA

View Full Version : flash header buttons not working


rubyhue
03-13-2009, 01:32 AM
I have created a flash header that I have placed inside an ap div tag in a Dreamweaver template. It has been working fine, but I made some revisions to the template and and swf file. Now the when I upload the site the swf buttons are not working. I have no clue why it's not working. The buttons work fine when I test it in Flash and Flash player, but not in Dreamweaver. Please help!!!!

here is part of the code:

<div id="apDiv3">
<script type="text/javascript">
AC_FL_RunContent( 'codebase','http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,28,0','width','629','heigh t','400','src','grandhall_header2','quality','high ','pluginspage','http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash','wmod e','Transparent','movie','grandhall_header2' ); //end AC code
</script><noscript><object classid="clsidhttp://dreamweaverforum.info/images/smilies/biggrin.gif27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,28,0" width="629" height="400">
<param name="movie" value="grandhall_header2.swf">
<param name="quality" value="high">
<param name="WMODE" value="Transparent">
<embed src="grandhall_header2.swf" width="629" height="400" quality="high" pluginspage="http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash" type="application/x-shockwave-flash" wmode="Transparent"></embed>
</object>
</noscript>
</div>

edbr
03-13-2009, 01:47 AM
renmove <noscript> and </noscript>

rubyhue
03-13-2009, 02:35 AM
I removed the <noscript> and </noscript> and it seems to make some of the links work again, but its dropped the header to the bottom of the page. Any advice?

here is the link for the one of the pages I'm having trouble with

http://www.mystiquedining.com/pocatello/about_gh.html

edbr
03-13-2009, 02:40 AM
not without seeing some code or link, this is in an absolute positioned div sounds odd, that should not have changed any positioning

rubyhue
03-13-2009, 02:49 AM
Here is more of the code:

<style type="text/css">

body {
background-color: #000000;
background-image: url(../Images/gradient_background.png);
background-repeat: repeat-x;
}
#apDiv1 {
position:absolute;
left:50%;
top:10px;
width:850px;
height:700px;
z-index:1;
margin-left: -425px;
}
#apDiv2 {
position:absolute;
left:50%;
top:10px;
width:879px;
height:326px;
z-index:10;
margin-left: -439.5px;
}
#apDiv3 {
position:absolute;
left:50%;
top:30px;
width:629px;
height:400px;
z-index:9;
margin-left: -314.5px;
}
#apDiv4 {
position:absolute;
left:50%;
top:242px;
width:762px;
height:489px;
z-index:2;
margin-left: -381px;
}
#apDiv5 {
position:absolute;
left:50%;
top:740px;
width:633px;
height:27px;
z-index:5;
color: #CCB575;
font-size: 10px;
font-style: normal;
margin-left: -318px;
}

#apDiv6 {
position:absolute;
left:50%;
top:645px;
width:316px;
height:77px;
z-index:6;
margin-left: -158px;
}
#apDiv8 {
position:absolute;
left:50%;
top:355px;
width:211px;
height:201px;
z-index:8;
margin-left: -211px;
}
#apDiv7 {
position:absolute;
left:50%;
top:355px;
width:213px;
height:202px;
z-index:8;
margin-left: 0px;
}
#apDiv9 {
position:absolute;
left:50%;
top:336px;
width:424px;
height:207px;
z-index:8;
margin-left: -212px;
}
</style>
<script src="../Scripts/AC_RunActiveContent.js" type="text/javascript"></script>

<div id="apDiv4"><!-- TemplateBeginEditable name="EditRegion1" --><img src="../pocatello/grandhall/images/master_background1.png" width="762" height="432"><!-- TemplateEndEditable --></div>
<div id="apDiv5">
<div align="center">this site requires FLASH <a href="http://get.adobe.com/flashplayer/"> get FLASH player</a> All trademarks &amp; copyrights are property of their respective owners</div>
</div>
<div id="apDiv1">
<div align="center"><img src="../Images/gold_frame1.png" alt="gold frame" width="795" height="705" /></div>
</div>
<div id="apDiv2"><img src="../pocatello/grandhall/images/curtain_top2.png" width="879" height="326"></div>
<div id="apDiv3">
<script type="text/javascript">
AC_FL_RunContent( 'codebase','http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,28,0','width','629','heigh t','400','src','../pocatello/grandhall_header2','quality','high','pluginspage', 'http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash','wmod e','Transparent','movie','../pocatello/grandhall_header2' ); //end AC code
</script><object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,28,0" width="629" height="400">
<param name="movie" value="../pocatello/grandhall_header2.swf">
<param name="quality" value="high">
<param name="WMODE" value="Transparent">
<embed src="../pocatello/grandhall_header2.swf" width="629" height="400" quality="high" pluginspage="http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash" type="application/x-shockwave-flash" wmode="Transparent"></embed>
</object>
</div>
<div id="apDiv6">
<script type="text/javascript">
AC_FL_RunContent( 'codebase','http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,28,0','width','316','heigh t','77','src','../pocatello/bottom_btns','quality','high','pluginspage','http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash','wmod e','Transparent','movie','../pocatello/bottom_btns' ); //end AC code
</script><noscript><object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,28,0" width="316" height="77">
<param name="movie" value="../pocatello/bottom_btns.swf">
<param name="quality" value="high">
<param name="WMODE" value="Transparent">
<embed src="../pocatello/bottom_btns.swf" width="316" height="77" quality="high" pluginspage="http://www.adobe.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash" type="application/x-shockwave-flash" wmode="Transparent"></embed>
</object>
</noscript>
</div>

and here is the link
http://www.mystiquedining.com/pocatello/about_gh.html

Ricky55
03-13-2009, 11:16 AM
Just on a separate note this page doesn't view properly at all in IE 6.

You've used transparent pngs and not provided a fix for IE.

You may be intending to do this I don't know but just so you know.

rubyhue
03-13-2009, 05:08 PM
Thanks for the heads up. I figured out the solution to my buttons not working. My z order put the flash file behind the image at the top of the page, and it was stopping the buttons.

How do I fix my transparent pngs to work for IE?

Ricky55
03-13-2009, 08:45 PM
You need to use one of these solutions. They aren't perfect but do work with limitations. I try not to use PNG's unless I really have to. Usually you can make do with a gif or just a jpg and just take it with the background colour. PNG's are larger file sizes anyway especially with transparency so I would only use them when you must.

http://24ways.org/2007/supersleight-transparent-png-in-ie6
http://www.twinhelix.com/css/iepngfix/

Important you do this though, when viewed in IE 6 the site is just a white block.

Which is a shame as its a very nice looking piece of work. IE6 is still quite popular unfortunately so you need to do this.

rubyhue
03-13-2009, 09:25 PM
Thanks for the links! I will definitely take care of it.

Ricky55
03-13-2009, 10:23 PM
nice one.

They're fairly straight forward but get back to us if you need any help with them.