PDA

View Full Version : Cant get my pages to match the template


KirstyBond
03-01-2009, 08:33 PM
Basicaly I'm creating a site in Dreamweaver CS3.

I have a CSS page and a template page, and then all the other pages I want on the site. And I'm using asp for the server

I've changed the name of one of the links in the nav bar which works in the template but not on the other pages when I upload the site to the server and I have the same problem with a photo I want as the header.

This is my CSS code...

@charset "utf-8";
/* CSS Document */


body {
font-family: Geneva, Arial, Helvetica, sans-serif;
font-size: 12px;
background-color:#7d9679;
text-align:center;
padding:0;
margin:0;

}
#container {
width:720px;
background-color:#FFFFFF;
margin:5px auto 0 auto;
color:#000000;

}
#header {
width:720px;
background-image:url(Art%20Work/IvyHouseWarboys/img/header.jpg);
height:140px;
border:#000000 thin sold 1px;

}


#footer {
margin: 10px 0 10px 0;
font-size:10px;
color:#000000;
}

#footer a { text-decoration:none; color:#000000; font-weight:bold;}

#footer:link { text-decoration: none; color:#000000; font-weight:bold;}

#footer a:visited { text-decoration: none; color:#000000; font-weight:bold;}

#footer a:hover { text-decoration: underline; color:#000000; font-weight:bold;}

#footer a:active { text-decoration: none; color:#000000; font-weight:bold;}

#navbar {
color:#000000;
background-color:#8B052B;
text-align:center;
font-size:12px;
font-weight:bold;
padding: 5px 0 5px 0;
margin: 10px 0 10px 0;
height: 18px;
width:720px;
}


#navbar a {
display:block;
float:left;
width:120px;
text-align:center;
color:#FFFFFF;
background-color:#8B052B;
font-size:12px;
font-weight:bold;
text-decoration:none;
width: auto;
padding: 1px 5px;
margin: 0 10px;
}

#navbar:link {
text-decoration: none;
color:#000000;
}

#navbar a:visited {
text-decoration: none;
color:#FFFFFF;
}

#navbar a:hover {
text-decoration: none;
color:#000000;
background-color:#f1e8e8;
}

#navbar a:active {
text-decoration: none;
color:#000000;
background-color:#f1e8e8;
}

#content {
padding: 5px 0 5px 0;
margin: 20px 20px 20px 20px;
width: auto;
height: 350px;
overflow: auto;
}

#form {
margin: 0;
padding: 0;
}

#content h1 {
font-size: 14px;
font-weight:bold;
}
#content h2 {
font-size: 14px;
font-weight:bold;
color: #BB0F17;
}

.scroller {
height: 300px; overflow: auto;
}


and this is my template code

<%@LANGUAGE="VBSCRIPT" CODEPAGE="65001"%>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"> (http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd)
<html xmlns="http://www.w3.org/1999/xhtml"> (http://www.w3.org/1999/xhtml)
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<title>Ivy House Warboys</title>
<link href="ivhouse.css" rel="stylesheet" type="text/css" />
</head>

<body>
<div id="container">
<div id="header">Content for id "header" Goes Here</div>
<div id="navbar"><a href="default.asp">Home</a><a href="accommodation.asp">Accommodation</a><a href="prices.asp">Prices</a><a href="contact us.asp">Contact Us</a><a href="meals.asp">Meals</a><a href="directions.asp">Directions</a><a href="links.asp">Links</a></div>
<div id="content"></div>
<div id="footer">&copy; ivyhousewarboys.com 2009 Site by <a href="http://www.stonehamsolutions.com">Stoneham (http://www.stonehamsolutions.com/) Solutions</a> </div>
</div>
</body>
</html>

and this is the link to the site (http://www.ivyhouse.stonehamsolutions.com/)


PLEASE HELP ME!!!!

domedia
03-01-2009, 09:01 PM
The image you are calling is not on the server.
Check yourself:
http://www.ivyhouse.stonehamsolutions.com/Art%20Work/IvyHouseWarboys/img/header.jpg

KirstyBond
03-01-2009, 09:03 PM
Ok so how do I get it on the server?

d a v e
03-01-2009, 09:10 PM
Ok so how do I get it on the server?
trick question? :)

put it there - upload it by ftp or use PUT in dreamweaver if it is missed out when you synchronise the site

KirstyBond
03-01-2009, 09:18 PM
Well I uploaded the pic I used onto the server and still not workin?

KirstyBond
03-01-2009, 09:18 PM
ok thanks i've managed to get it up. now how do I get the nav bar to change?

domedia
03-01-2009, 11:25 PM
You have to make sure that the CSS file is pointing to exactly where the file is.