PDA

View Full Version : Site works in Firefox but not in IE


stasfiestas
01-04-2009, 05:08 PM
Hello everyone, Im new in this forum and also new with dreamweaver.

Well I have made a website, for a school assingment (we had to make a portfolio about ourselves) So I did, and my site looks good.. in firefox.
in the internet explorer the text is in all different places then it should be,
http://www.stasfiestas.com thats my website,

please if you know what I can do please tell me, :-)

(oh by the way I work with dreamweaver 8)


Thank you very much! :grin:

domedia
01-04-2009, 05:57 PM
Hi stasfiestas and welcome to the forums!

Frankly I have not worked with tables for layout for a loong time, so I'm not sure how you can fix it. I think there's plenty of other people here that might help though.

If you're thinking about web design as a long term investment (doing it after school), I'd look at learning HTML and CSS asap. This will help you solve issues like this easily.

Cary
01-04-2009, 08:34 PM
One of your cells is missing a height.

The table's total height is 700px with the first row being 192px high.

This leaves 508px for the second row.

The second row has 3 columns with the middle column being used for the language links, so it is split into another 6 rows.

The first five rows or cells in this middle column have heights, but the bottom cell/row in that column does not have a height, so the link cells compress it and shift down in IE.

Generally, "height" is treated as absolute by other browsers, but IE treats it like a minimum height which can't get shorter, but it can grow if it has the space.

Cary
01-04-2009, 08:50 PM
I forgot to mention you didn't close your opening body tag with ">".

stasfiestas
01-04-2009, 08:53 PM
hi, thanks for your reply!

ok so what i understood is that i have to put the hight and width numbers into dream weaver, right? well i've done that, i put like you said something about 192 and 508 etc etc, so after i put all the numbers, it looks very good in dreamweaver, and then i look for it in IE and FireFox.. and now in both browsers it looks the way it shoudn't...

:(

ok please what can i do to fix this?

Cary
01-05-2009, 01:52 AM
Go back to the center column which you divided into 6 rows. The bottom cell, below Nederlands, needs a height.