PDA

View Full Version : Intended display not achieved...


airwick
12-25-2008, 12:47 AM
Seasons greetings everybody.

Would just like to ask for your expert answers regarding my issue:

I recently helped a friend with their website. I used Dreamweaver, it's my first attempt to use it. Things we're ok, I managed to tweak the template. It looked great on my local preview, but looks crappy on the web (please see test link on my server):

http://gabrielmultimediagroup.com/commlink/

The real look is this:

http://gabrielmultimediagroup.com/commlink/commlink-web-final.jpg

Questions:
1. Does it have something to do with CSS settings and stuff?
2. How does one address the LINKing of images and files from within Dreamweaver. I noticed from the pagesource on the index file uploaded, the reference for the images are still local? Is there a way to automatically change it locate the files on the server?

THANK YOU IN ADVANCE.

airwick

Ricky55
12-25-2008, 01:07 AM
It looking mainly to do with images being missing.

Yes it is, look here <IMG SRC="file:///D|/Data and Docume

This path is pointing to a location on your hard drive not on the web, we had a post earlier similar to this.

When linking images or anything for that matter you have two options available to you.

You can either specific a absolute path or a relative one. Generally for images you would specify a relative one.

An absolute path would be for example

http//:www.yoursite.com/images/someimage.jpg

A relative path means relative to your document. So think of it this way, create a folder on your PC to hold the website, then create folders within this main folder to hold things like images, a relative path would then look like

images/someImage.jpg

In this instance the web browser would look in a folder called images and then for a file called someImage.jpg.

To correct this ensure all the images relating to the site or page are saved in a folder called images and this folder is in the main root folder for the site. Open the HTML file up in Dreamweaver, and select the placeholder for each image and then simply point Dreamweaver to the file so it sets the paths properly.

airwick
12-25-2008, 11:50 AM
Hi Ricky,

Thank you so much. I realized that the images are being linked to a local drive or folder. I guess I can solve that easily. Thanks so much.

My major problem is the layout. How do I reflect the INTENDED DESIGN (the one on the screen captured image) unto the live website?

Thanks once again.

-airwick

coloeagle
12-26-2008, 05:32 PM
My major problem is the layout. How do I reflect the INTENDED DESIGN (the one on the screen captured image) unto the live website?
To correct this ensure all the images relating to the site or page are saved in a folder called images and this folder is in the main root folder for the site. Open the HTML file up in Dreamweaver, and select the placeholder for each image and then simply point Dreamweaver to the file so it sets the paths properly.You need to start by correcting this problem.