PDA

View Full Version : inconsistencies inserting a class


jcrave
12-14-2008, 05:47 PM
Hello,
I am trying to create a border and a margin around individual photos in a gallery. I am doing this by creating a "class" and then applying that to the individual photos.

I have done this before in the exact same site. I had to completely redo the site because I didn't create an editable region on the template. Now I have an editable region and am trying to create the border around the individual photos. But when I select the photo to create the class it either doesn't do anything or the selection covers much wider area than the photo. It is never exactly on the photo.


Anything will help....thank you.

coloeagle
12-14-2008, 05:58 PM
Just to confirm my understanding, are you using css to create the border styles?

jcrave
12-14-2008, 06:01 PM
yea. I go to insert div tag and from there I go about creating a class. Not sure if that is the right way, but its the only way I have it.

coloeagle
12-14-2008, 06:08 PM
Can you provide a url or post your code/s

jcrave
12-14-2008, 06:15 PM
This is all really new to me, so I am just grabbing what I think you will need...

jcrave
12-14-2008, 06:15 PM
<td colspan="8" rowspan="17"><!-- TemplateBeginEditable name="Main_Content_Area" -->
<div id="site_layout_content">
<div id="site_layout_content2">
<table width="500" height="332" border="0" align="center">
<tr>
<th align="left" valign="top" scope="col"><div class="pictures"><img src="Thumbnails/gallery01.jpg" width="100" height="150"></div>
<img src="Thumbnails/gallery02.jpg" width="150" height="100"></th>
</tr>
</table>
</div>
</div>
<!-- TemplateEndEditable --></td>

jcrave
12-14-2008, 06:17 PM
this is the site I am working. Before I had the problem with the class.
http://fastfood.morheadproductions.com/pictures.html

coloeagle
12-14-2008, 06:25 PM
Try removing the div and place the pictures class inside the img tag

coloeagle
12-14-2008, 06:46 PM
Just noticed and this may not be any help. You have the div/image inside a th(table Head) and not a td(table Data) cell

jcrave
12-14-2008, 06:56 PM
I removed the div tag and i placed the pictures class inside the image tag. In firefox it looks good, but in the design view all the slices went out of place.

jcrave
12-14-2008, 07:03 PM
<td colspan="8" rowspan="17"><!-- TemplateBeginEditable name="Main_Content_Area" -->
<div id="site_layout_content">
<div id="site_layout_content2">
<table width="500" height="332" border="0" align="center">
<tr>
<td align="left" valign="top" scope="col"><div class="pictures"><img src="Thumbnails/gallery01.jpg" width="100" height="150" class="pictures"><img src="Thumbnails/gallery02.jpg" width="150" height="100" class="pictures"></div> </td>
</tr>
</table>
</div>
</div>
<!-- TemplateEndEditable --></td>

jcrave
12-14-2008, 07:04 PM
actually I meant to post this one below......

jcrave
12-14-2008, 07:04 PM
<td colspan="8" rowspan="17"><!-- TemplateBeginEditable name="Main_Content_Area" -->
<div id="site_layout_content">
<div id="site_layout_content2">
<table width="500" height="332" border="0" align="center">
<tr>
<td align="left" valign="top" scope="col"><img src="Thumbnails/gallery01.jpg" width="100" height="150" class="pictures"><img src="Thumbnails/gallery02.jpg" width="150" height="100" class="pictures"></div> </td>
</tr>
</table>
</div>
</div>
<!-- TemplateEndEditable --></td>

coloeagle
12-14-2008, 07:12 PM
Remove the /div from the image td

jcrave
12-14-2008, 07:18 PM
Nice! Thank you so much.

If you can take a look at my other post, http://www.dreamweaverclub.com/forum/showthread.php?t=30513, that would be a great help too.

coloeagle
12-14-2008, 07:21 PM
Your welcome, glad to help.

Will do, just a quick note and I had meant to mention this earlier. When posting code be sure to use the code tags. Makes the code easier to read.