PDA

View Full Version : WAMP Problem


tux
10-27-2008, 10:21 AM
I restarted me laptop this morning and Started WAMP but it is only showing the yellow icon in the system tray. I have tried stopping and restarting all services and restarting the laptop but still cant get WAMP to fully start.

The only recent change I have made is to install Nero9.

Does anyone know what the problem might be and what I should be looking for or does any one know of a conflict issue with WAMP and Nero9.

Cheers.

Paul

davidj
10-27-2008, 12:50 PM
there could be a problem with another App using port 80

click the following from wamp Icon...

Apache / Service / Test port 80

this will tell you what is using the port and may give you a clue.

You mentioned installing Nero

this could have installed a listener for updates which is hogging the port. Even though nero is not running you may want to check your services to see if any nero listener is running.

tux
10-27-2008, 12:57 PM
Cheers David,

I tested port 80 as you suggested and get this.....

"Your port 80 is actually used by: Server: Microsoft-IIS/7.0"

How would I check my services to see if Nero has a listener running.

Thanks mate.

lux
10-27-2008, 01:32 PM
if you have IIS running then you must stop the service before you can start and use apache.

one way to stop IIS is to open a command prompt window and enter the following command:

iisrest /stop

once you get a notification that iis has been stopped open up wamp and click start services

davidj
10-27-2008, 02:38 PM
also

go into your services under administration tools (control panel)

in services you should see an entry regarding IIS. Click it and in properties choose startup type -> manual as apposed to startup type -> automatic

This will stop it happening next time you boot your machine

NOTE:you can also start and stop services from this dialogue

lux
10-27-2008, 02:46 PM
sorry, typo in my previous post;

iisrest /stop

should be

iisreset /stop

tux
10-28-2008, 06:54 AM
Thanks for all the advice guys, got it sorted.

I run Vista and this is what I did if it helps others.

I did what LUX suggested first. Run isnt visible like in XP so went....

Start/All Programs/Accessories/Run and typed in cmd to get the prompt, entered iisreset / stop and hit return.

Then I went to Control Panel/Programs and Features/Turn Windows Features On or Off. From here remove the tick or shading from Internet Information Services.

Restart your computer and then WAMP should start normally.

Hope this helps someone, regards

Paul