PDA

View Full Version : Links break when I upload edited files. Help!


Oldsurf
08-26-2008, 06:50 PM
I've always been perplexed by this problem, please help!
Why is it that when I make a slight change to my index.html main page, and then upload it to my website, all the links break? When you upload a freshly edited index page to the hosting server, what also must you upload? Do all of the index page's images have to go along for the ride as well, even though they're not changing?
I discovered this to be the case, but why? Am I doing something wrong? Prior to editing and uploading a new index page, the website was fine.
Thank you!

domedia
08-26-2008, 07:55 PM
Never heard about this before.. you're doing something wrong

Oldsurf
08-26-2008, 10:30 PM
I'm not sure what could be wrong, but when you make changes to an index page, do you need to send up all the graphics embedded/appearing on that page.?

edbr
08-27-2008, 01:10 AM
check the paths to your images in the edited page are correct first

Corrosive
08-27-2008, 07:32 AM
I'm not sure what could be wrong, but when you make changes to an index page, do you need to send up all the graphics embedded/appearing on that page.?

You really shouldn't need to upload the images every time you make a change to your index page but it's really hard to tell what you might be doing wrong.

Oldsurf
09-01-2008, 10:15 PM
I'm not sure what the answer is to my question, but things are working now. I upload the Index page, and the pages affected by an index page link change, and all is fine. I'll just stick with what works, and maybe answers will come later. Thanks everybody.

neonfluxx
09-01-2008, 10:30 PM
post your code and let us check it out.