PDA

View Full Version : Image viewer with .swf not showing up


Labecs
07-13-2008, 10:37 PM
Can someone point me in the right direction to learn why the image viewer with the .swf I put on my page is not showing up in my page, please?

Thanks!

Cary
07-14-2008, 12:18 AM
Not without being able to see the page. Check if all the needed files are uploaded and in the correct locations.

Ricky55
07-15-2008, 05:59 AM
This question must get asked at least once a week and the reason is always the same especially if you are just seeing a White space where your flash content should be.

Like Cary said ensure all files are uploaded to the server especially the script file that is used to embed the swf. Also ensure that you haven't done anything stupid like saving the swf outside of the site.

If you are using the insert flash button in dw cs3 or dw8.02 then this should work fine.

rcsjackson
10-30-2008, 09:06 PM
I am new to web design and DW. I have basic understandings and think I have tried every answer I've come across for this. I am having the same problem. As far as I can tell, everything has been uploaded correctly. The page having the problem is www.haveyousparkledtoday.com/bioionic.html

I created the page in DW CS3, added the image viewer, told it which photos to use, can preview it successfully in DW, save the html and open that with Firefox and i previews offline fine. Once online it's just the white, no controls or anything. If I try and open the SWF file offline, it comes up blank, but the controls are there. The photos are in the images bin of my FTP client and the swf is in the same section as the html files.

Thoughts?

Thanks in advance.

rcsjackson
10-30-2008, 09:18 PM
Oh, if I type in www.haveyousparkledtoday.com/bioionic.swf it pulls up a blank swf with controls and the incorrect size.

Cary
10-30-2008, 10:02 PM
Works fine with javascript turned off. This file is missing:

http://www.haveyousparkledtoday.com/Scripts/AC_RunActiveContent.js

rcsjackson
10-30-2008, 10:10 PM
I hadn't even noticed that DW created a "scripts" folder in my website bin. Thank you so much!! I knew it was something obvious.

Cary
10-30-2008, 11:38 PM
If things don't work right, double-check the links in your page. The link to this script is right in the head of the page.