View Full Version : Rollover issue

06-11-2008, 10:30 PM
I have no idea why, but for some reason my roll over image no longer changes image when i roll over it.

Can anyone suggest a possible reason? what could possibly have caused it to not work?

heres the code

<div style="width:93px;">
<a href="../index.html" onMouseOver="MM_swapImage('Home','','../IMAGES/Buttons/HomeON.png',1)" onMouseOut="MM_swapImgRestore()"><img src="../IMAGES/Buttons/Home.png" alt="Home" name="Home" width="93" height="38" border="0" id="Home">

i didn't write this code from scratch, its from my dream weaver actions.


06-12-2008, 05:57 AM
has it worked before

have you tried testing in other browsers

have you tried removing the behaviour and replace it again

try replacing the png's with jpgs or gif's

(normally if a person has written it from scratch and has taken the time to do this i would gladly take my time to help debug it but as you have used a behaviour then i suggest removing the old behaviour and re-using the behaviour )

06-12-2008, 12:56 PM
Hi Swift, the code you pasted looks fine.

I would do as DJ suggested and remove then then reapply the behavior. It is possible the javascript in your head area has gotten changed.

06-12-2008, 09:32 PM
It used to work. its real weird how it stopped.
I have tried reapplying the behavior, does nothing. but i'm going to try it again.

06-13-2008, 12:30 AM
alright, so reapplying the behavior doesnt do anything. i tried removing all the images, and putting them back in, reapplying the behaviour, nothing.

Any ideas?

06-13-2008, 01:09 AM
no in blind.. do you have this online anywhere?

06-13-2008, 01:48 AM
unfortunately no, i have yet to host it, i'll keep fiddling with it. when i fix it i'll post again.

EDIT: FIxed! i looked and for some reason the swap image script was embedded in the spry effects script. through the code i removed it all and reapplyed the swap. apparently just removing the behav doenst get rid of the code.

Thanks for the help all!

06-13-2008, 06:04 AM

the wonders of drag-n-drop behaviours

06-13-2008, 09:44 AM
They do like to leave their 'mark' behind...
A bit like 'uninstalling' a program by deleting it from your C:Drive 'Programs' folder - lol!

06-13-2008, 09:49 AM
They do like to leave their 'mark' behind...

They certainly do. Once I have a page design finalised I start again, from scratch, just to avoid the detritus left behind by constantly changing my mind :wink:

06-13-2008, 02:11 PM
My post is meant to say C Drive but the colon i used made it a smiley...
Strange world.

06-13-2008, 02:19 PM
i have whinged about this before but it fell on deaf ears!

and it is completly out of character for me to whinge and whine on about stuff.

06-13-2008, 03:54 PM
What's falling on deaf ears DJ ?

06-13-2008, 04:02 PM

06-13-2008, 04:06 PM
...what statement/advice of yours is being ignored ?

06-13-2008, 04:31 PM
oh right... haha

nah i mentioned it to the BOSS (Ove) and he told me to sling my hook

i wanted the smiley bastards disabled as you encountered bugs

06-13-2008, 08:00 PM
hehe yeah.. DJ hates smilies and I need them so people don't think I'm a **** ;)