View Full Version : Changing WWW Directory in WAMP

05-12-2008, 11:05 PM
How can I change it ?
I'm following the tut and want to point it to where my internerd files are kept but I can't figure how to point it ?

Help please.
Enjoying the TUTs !

05-13-2008, 05:35 AM
you can use an alias

click the wamp icon in the systems tray and select alias then follow the instructions

05-13-2008, 07:05 AM
Cheers DavidJ - I'll take a look later.
My pop up menu is different (slightly) in the version I'm using so I hope it doesn't cause any problems...
I think my version of the MySQL software is a later version to. I'm sure i'll find everything tho...

I've been given special dispensation to disappear on the computer as I'm "doing my course"... Glass of wine... and we're ready !


05-13-2008, 06:51 PM
hey David - I've done that but my www directory still defaults to the WAMP folder... will this cause me problems ?

05-13-2008, 10:32 PM
nope not while your testing

your alias works yes?

05-13-2008, 10:42 PM
Works how ? I'm not sure I know what it does...

05-13-2008, 10:53 PM
an alias allows you to select any directory on your machine and the contents will be processed by PHP through Apache

05-13-2008, 11:20 PM
Welll I set one up... still the same error...
I'll reconfigure WAMP and come back...

05-17-2008, 10:22 PM
So... I went to reconfigure... tried using Neon's setup.

He goes to PHPmyadmin in the WAMP folder... I don't even have this folder & when I hit PHPmyadmin from the WAMP start menu I get error "403 Forbidden".

I really want to get this working but I'm getting so fecked off with it.


05-17-2008, 10:26 PM
all i can sugest is to uninstall and follow the install from scratch

if you go to C:/wamp/www

that is your working directory

05-17-2008, 10:35 PM
Sorry to be an arse... what do you mean when you say 'Working Directory'?

This is where my files should be ? (it's not)
I created an alias and pointed it to the folders where my PHP tutorial files are - is this wrong? (ie; local root / web root)

05-17-2008, 10:38 PM

so your alias is setup

is your address correct


05-17-2008, 10:43 PM

Inside here are connections & images folders.

05-17-2008, 10:46 PM

if you can see that in your browser you just need an index.php and then your set

05-18-2008, 09:02 AM
Cheers David... Where exactly do I have the index.php ?
http://localhost/test/index.php ?
I'm not retarded I promise - I can't believe how alien this is to me...

I'm reinstalling mySQL at the mo so I'll be back on it shortly....

Cheers DJ

05-18-2008, 09:39 PM

that is correct


inside the index.php add an echo


echo "test";


add this in the body then browse that page


see if you see the text on the page

05-18-2008, 10:07 PM
So... I reinstalled MySQL and it's all gone wierd...

It now already has a host so I can't set it up as per tutorial...
When I double click on 'Tutorial on Localhost" (I named it that) I get this error:

Error Code: 1045
MySQL server uses client's login ('rob' in your case) and the name of the client computer which it tries to set the connection from for the client authentication. In your case the reason is that your 'rob' user from your client computer doesn't have permissions to access this MySQL server.

To solve this problem you should grant the necessary permissions to user rob@<client_computer_name>.
You can do this with the help of User Manager tool of SQL Manager.

I've uninstalled mysql 4 times now but i'm still not getting to 'start again'... Is there a way of deleting it's memory ? I want to start again and see where I went wrong...

05-19-2008, 05:44 AM
sorry rob

all i can suggest is that you uninstall, delete all directories and start again

out of everyone who has attempted the tutorials you have won the award for falling at the first hurdle! hehe.

do you have any application that uses port 80 like skype? if so close it down.

the only other suggestion is to try another version of wamp or install each component separately.

05-19-2008, 12:11 PM
Thanks David. I already feel like a 'tard, making it public was the last of my intentions ! :rolleyes:

I will not post again until I have corrected the errors of my ways. haha...

Bye. I may be some time.

05-19-2008, 06:26 PM
dont worry bout it

we need to get it sorted

delete all folders after you have removed WAMP

05-19-2008, 06:57 PM
Feck me. This is getting tiresome.

I've reinstalled WAMP & EMS and I still don't get the options I need.
In the databases window in EMS - If I right click I don't get a "register host" option anymore... just a "Show Hosts" option. But there are no hosts ie; mysql on loacalhost.

If I show hosts - nothing.
If I hide hosts - nothing.

I uninstalled and deleted all folders.
Reinstalled both.


05-19-2008, 07:25 PM
have you successfully installed WAMP

have you tried php. Is it working