PDA

View Full Version : Page loading oddly in IE7


mek113
04-30-2008, 05:49 PM
I'm working on a website for a client that when loading the pages for the first time, the css-styled vertical navigation (using lists) and some text in the header (using absolute positioning) are appearing temporarily before the entire page loads. I'm somewhat new to CSS and have done about 5 website using CSS and this is the first time that I've had this problem. I've run the Dreamweaver validation and nothing shows up and this problem does not occur in Firefox.

Is it okay if I post the URL for someone to look at?

mek113

domedia
04-30-2008, 07:04 PM
Yes please post url's, they help bigtime:)

Not sure what the 'problem' is yet. Is it the way the page loads?

Cary
05-01-2008, 12:02 AM
You can try putting this code in the head of your html:

<script type="text/javascript"> </script>

Read more about Flash of Unstyled Content (http://www.bluerobot.com/web/css/fouc.asp/) (FOUC).

mek113
05-01-2008, 03:32 AM
The URL is: www.meyerimplement.com (http://www.meyerimplement.com)

What you should see, only briefly before it goes to the actual page, is standard blue links for the navigation, which I've done in CSS as a list. Also the text that I set as absolute in the header shows up in the lower center of the page. Again, this happens in IE7, not Firefox. And it appears very briefly but if someone is on dial up, which the audience for this website could be, it may appear longer, which is what concerns me.

mek113

Cary
05-01-2008, 04:32 AM
You can try putting this code in the head of your html...

Or just use the link tag instead of @import url("styles.css");