PDA

View Full Version : Problem displaying tables in Internet Explorer


Kingi123
01-25-2008, 08:01 PM
Hi all. I have just finished a website in Dreamweaver using just the design mode. Time was pushing so I haven't got my head around HTML yet but it is definitely on my to-do list, especially after viewing my site in Exoplorer.

The site is contains a lot of tables and I designed it on a Mac, frequently checking the preview in Firefox and Safari. As soon as I was happy with the site I launched it (www.coletteali.com (http://www.coletteali.com)). Once it was live I checked it on I.E. 7 on a PC and the layout is all over the place.
If anyone has any ideas on how to fix this I would really grateful. Thanks in advance.

domedia
01-25-2008, 08:40 PM
I validated your code, and found your table structure is broken.
<td width="418" height="20" align="left" valign="top" bgcolor="#D4BFAA"> </tr>

<td height="507" valign="top" bgcolor="#E5CDB7"><div align="left" class="style8">
A </tr> can *only* be followed by another row, or a closing table tag.
My guess is that it's missing a <tr> tag since the next line is a starting <td>

You can check your site for valid code here:
http://validator.w3.org/

Kingi123
01-25-2008, 10:47 PM
Hi, Thanks for that. i tried the <tr> tag but it seemed to throw things out even more. Have I put it in the right place?

d a v e
01-26-2008, 06:27 AM
fix your html errors - check your opening and closing tags
http://tinyurl.com/2qtz44

and learn some html ;)

mangofreak
01-27-2008, 02:05 PM
As Domedia says, you have errors in your page. 34 errors is what the W3C validator shows. I checked your site in IE 7 as well as in Firefox and I cannot see any major difference or problem. Can you explain what are you looking at? what is the problem that you see?