PDA

View Full Version : newbie to templates - need help pls


Jenny Brandis
01-07-2008, 07:21 AM
my website was handcoded way back in 1996-2000 and as it is over 400 pages I decided to use templates to make global changes.

Sound good so far?

Well, I messed up somewhere. Most of the site uses the template overall.dwt but my craft section uses craft_template.dwt. Both templates are now in th e template folder with the matching css in the root directory.

Some of the site www.brandis.com.au/genealogy/gendata (http://www.brandis.com.au/genealogy/gendata) folder in particular seems to have come unstuck or something. All the links are looking for files on my hard drive. Great for me while it is on the hard drive but hopeless now it is online.

Can you tell me how I can fix this? I do know that when I try to save the overall.dwt it gives me an error code 3 for the gendata files so I am guessing that has something to do with the problem.

All assistance welcomed.

edbr
01-07-2008, 07:30 AM
you should update your files locally then upload the changed files to your server

Jenny Brandis
01-07-2008, 07:46 AM
I thought that is what I did. :confused:
when I look at the coding for the offending files they point to the files on the hard drive = with complete path
I did not realise this until I uploaded them and even then it was only when I checked at work. Until then of course the pages are accessing from the hard drive and I did not check the coding.
How do I fix this??

Jenny Brandis
01-12-2008, 08:09 AM
Not sure if this was the easiest way to fix it but ....
First off I made sure that the template pointed to the right thing - it didn't so I fiddled until I lost patience. Then I redid the template, correctly.
Opened each of the offending files and copy/pasted the data into new files based on the new template, then saved over the old file. then uploaded all of them.
It worked but I am sure there was an easier way- just not one I could find.