PDA

View Full Version : nightmare with point to file Help a newbi


kobi64
12-01-2007, 11:04 AM
Hi I'm using point to file to link from menu to pages
but after i click on the first link all other links point to the same page
even though i pointed the other text links on the menu to different pages.

here is the menu code

</div>
<!-- TemplateEndEditable --><!-- TemplateBeginEditable name="menu" -->
<div class="menu">
<div class="menu_title">Main menu</div>
<ul>
<li><a href="#" target="_self" class="menu_link">Home</a></li>
<li><a href="Faxless payday loan.html class="menu_link">faxless payday loan</a></li>
<li><a href="cashadvance.html" class="menu_link">cash advance loan</a></li>
<li><a href="how does it work.html" class="menu_link">How does it work </a></li>
<li><a href="#" class="menu_link"><a href="mailto:staff@paydayloanexplained.com">
Contact us </a></li>
<li><a href="about Us.html" class="menu_link">About Us </a></li>
</ul>
</div>
<!-- TemplateEndEditable -->

I thought it should be straight forward but for some reason i can't get it to work.

any help will be great
thanks Kobi :-D

lux
12-01-2007, 12:38 PM
one mistake i can see is:

href="Faxless payday loan.html

so change it to

href="Faxless payday loan.html"

davidj
12-01-2007, 06:55 PM
lux

you forgot to advise of the changes

kobi64
12-01-2007, 08:22 PM
Thanks Lux for your help
unfortunately still no luck with this
Cheers Kobi :grin:

davidj
12-01-2007, 08:26 PM
what lux was getting at was that your page references are incorrect

dont use spaces when naming and referencing files / pages. Sub spaces with underscores

also check you have terminated your quotes around the file /page ref in the href attribute

example...

you have failed to close the quotes somewhere in this line...


<li><a href="Faxless payday loan.html class="menu_link">faxless payday loan</a></li>

kobi64
12-02-2007, 10:29 AM
thanks davidj for your help I'll give it a try and see how it works
thanks again
Kobi

kobi64
12-02-2007, 11:42 AM
hi Ive tried to correct some of the code
with the suggestion of Lux and Davidj but still have the same problem.

I've linked from my menu in the index to other pages but only one link seems to work. what i mean is i could click on any of the links and it will take me to
the desired page but clicking on any other link will take me to the same page
here is the code hope someone have some suggestion

thanks
Kobi

<div class="menu">
<div class="menu_title">Main menu</div>
<ul>
<li><a href="index.html" class="menu_link">Home</a></li>
<li><a href="faxless_payday_loan.html" class="menu_link"> Faxless payday </a></li>
<li><a href="cash_advance.html" class="menu_link">Cash advance loan </a></li>
<li><a href="how_does_it_work.html" class="menu_link">How does it work </a></li>
<li><a href="About_Us.html" class="menu_link">About Us</a></li>
<li><a href="#" class="menu_link">Contact Us</a></li>
</ul>
</div>
<!-- InstanceEndEditable -->

davidj
12-02-2007, 11:45 AM
have you changed your file names to include the underscore

not the href values but the actual file names

kobi64
12-02-2007, 11:55 AM
yes i have, my file names
are index.html ,faxless_payday_loan.html,cash-advance.html etc..


thanks again
Kobi

davidj
12-02-2007, 12:02 PM
is the file cash-advance.html a dash or an underscore

also what happens when you click a link. whats happening to give you the idea its not working

kobi64
12-04-2007, 06:53 PM
Hi everyone :grin:

When i click on the link for the first time it will take me to
the right page clicking on any other links would leave me on the same page.
So initially The source code looks like this (in browser)
ul>
<li><a href="index.html">Home</a></li>
<li><a href="faxless.html">faxless Payday Loan</a></li>
<li><a href="cashadvance.html">Cash Advance</a></li>
<li><a href="howitworks.html">How it works</a></li>
<li><a href="aboutus.html">About Us</a></li>
</ul>

after clicking on the link
the source code looks like this

ul>
<li><a href="#">Home</a></li>
<li><a href="#">faxless Payday Loan</a></li>
<li><a href="#">Cash Advance</a></li>
<li><a href="#">How it works</a></li>
<li><a href="#">About Us</a></li>
</ul>

it looks like the path to files has disappear
i would like to mention that I'm using a template with
editable regions i don't know if it has anything to do with it but I'm trying to give as much information

Since my last post i've tried another template
and got the results.

thanks again for taking the time to read my post
I've been playing with it for the last couple of days without success
so any help anyone can offer will be great.

thanks again
Kobi :grin: