PDA

View Full Version : Dreamweaver FTP files connecting to TLS/SSL servers


tommisauce
09-27-2007, 12:03 PM
Using DW8 on a Mac:

I have recenty been commissioned to redesign a site. However the site has to connect via FTP with TLS/SSL - which Dreamweaver as far as I can work out isn't capable of. Does anyone know any different. I have actually found another FTP client to handle this for me - however as I'm designing in DW8 I would rather FTP via it as well. Any ideas?

Many thanks in advance.

domedia
09-27-2007, 01:24 PM
Secure FTP has been supported forever :) Check the checkbox that says 'secure FTP'

tommisauce
09-27-2007, 02:24 PM
I did & it didn't work - hence that's why I am asking the question. I thought it would work - I was surprised it didn't.

domedia
09-27-2007, 02:33 PM
I did & it didn't work - hence that's why I am asking the question. You have to be more specific . I've used it without a problem before, but it's impossible to troubleshoot based on that description. Most other FTP clients support SFTP the same way DW does. They all use the same protocol for this.

tommisauce
10-03-2007, 03:42 PM
The client has got another company hosting their site and the only way to connect to the server is via FTP with TLS/SSL. As previously mentioned I have tried DW8's SFTP - but no luck what so ever. The hosting company aren't being the most helpful either! The only way I've managed to connect to the server is through Fetch which has the FTP with TLS/SSL facility on it.

domedia
10-03-2007, 04:05 PM
'no luck what so ever' <= is not describing anything, and impossible for anyone to troubleshoot. :(
Can you be more specific? What is it about it that does not work? DO you get an error msg? What did the hosting company tell you? What are your server settings in DW? As I said previously, DW ships with support for SFTP.

or you could just use a third party FTP client, since that worked for you.

tommisauce
10-03-2007, 04:31 PM
Well the only message coming up is:
An FTP error occured -cannot make connection to host. Your login or password is incorrect. Please check your connection information.

However that info is the same as I've been inputting in Fetch - which works. I've inputted the info on so many occasions - its not a quesion of inputting the information incorrectly.

Any ideas?

domedia
10-03-2007, 05:36 PM
The error message is being sent from the server, so it's not something DW is making up. Double and triple check your username/password and make sure *all* other options of your connection is correct.

tommisauce
10-04-2007, 08:50 AM
I've not only triple checked the username/password - I've done it over ten times! :( I've checked over and over the info is correct in DW. As I've said previously Fetch doesn't have a problem with connecting FTP with TLS/SSL. I've even checked the 'server compatibility' box & chosen use alternative FTP method, but thats still not working. I'm all out of ideas - I gues I'll have to carry on using Fetch - it's not ideal but it works.

d a v e
10-04-2007, 10:39 AM
have you tried ticking the 'use passive ftp' check box in the remote settings in the DW site manager?

tommisauce
10-04-2007, 02:42 PM
I have used everything!! With different combinations and it still doesn't work.

d a v e
10-04-2007, 03:32 PM
try checking with the host?

MRogerson
03-02-2010, 01:40 PM
The client has got another company hosting their site and the only way to connect to the server is via FTP with TLS/SSL. As previously mentioned I have tried DW8's SFTP - but no luck what so ever. The hosting company aren't being the most helpful either! The only way I've managed to connect to the server is through Fetch which has the FTP with TLS/SSL facility on it.

Sounds like your client's server is using pureftp, which only supports the newer AUTH TLS and not the older AUTH SSL.

As far as I can establish DW does not support the new protocol, although I notice the beta2 version of Air does support TLS/SSL sockets, so maybe DW will in time.

The message you get back is exactly the same as soon as the pureftp server has 'TLS Only' checked.