PDA

View Full Version : Can't upload flash content


dadiop
08-16-2007, 12:04 PM
Hi All
I'm very new to this stuff and have been trying to develop a previously created website.

I have been uploading some flash video and flash animation to my site.
site is http://www.dialogueuk.com (http://www.dialogueuk.com/test.htm%29)

Managed to get all working in preview beautifully, but with the movies I discovered I had to upload the scripts too.Deeuh (can't write what Homer says). OK OK so I'm new at this..Anyway, I've been having fun with scripts and DW8. Since uploading the scripts file to my remote htpp docs folder, I can get a video file (http://www.dialogueuk.com/test.htm) (http://www.dialogueuk.com/test.htm%29) working on the web. Should I not have expected DW to have upload this script file automatically when putting a file? - ie have I missed a preference setting or is it always manually done via the '2 window panes'/remote&local view thingy? This was a video file - angela.flv. So all is lovely in that garden.

Now I'm trying to get a little flash animation movie up on a new page If you look at http://www.dialogueuk.com/spanish.htm (or CARTON link on home page) you'll see three tel numbers. 2 of these have links which then go to http://www.dialogueuk.com/flyingpie.htm (when you click on the 2 'duff' answers.) This link works fine but when you arrive on flyingpie.htm you should see a custard pie across the screen with "WRONG!" Silly I know but ... (This flash file file was converted from an fla to a swf and has been placed inside a large table on the flyingpie page). Anyway, on my DW preview it works fine but not on the web page. I've tried re-uploading the scripts as well via the local/remote sites dual pane, but I get my old favourite each time i upload the flyingpie.htm page:

httpdocs:flyingpie.htm - Put operation successful
httpdocs:dialogue.css - same - not transferred
httpdocs:dialogue-print.css - same - not transferred
Scripts/ - error occurred - Unable to create remote folder Scripts/. Access Denied. The file may not exist, or there could be a permission problem.
Scripts:AC_RunActiveContent.js - user cancelled

File activity incomplete. 1 file(s) or folder(s) were not completed.
Files updated: 1
Files skipped: 2

Files with errors: 1
Scripts/

Is there something about manipluating the Javascript behaviours - don't get excited - haven't a clue what it means really. I've seen other people posting similar problems on other forums, but can't seem to find an answer.

Cheers again and sorry to be so longwinded
Rob

Ricky55
08-16-2007, 03:25 PM
AC_RunActiveContent.js must be present on the server or the flash content will not be displayed. This is the scipt that is used to embed the content into the HTML page. This file should be in the site root in a folder called scripts

Dreamweaver should upload this automatically though.

Make sure locally you have a folder in your site called scripts with the AC_RunActiveContent.js in it. If you have just check on the remote server to see if its there, if not try just uploading this file on its own.

Let me know how you get on.

Ricky55