PDA

View Full Version : Cannot get DW testing server to work


codemangler
07-27-2007, 07:44 PM
Is there a special configuration for getting the testing server to work with DW when your apache DocumentRoot is NOT htdocs?

Whichever way I try I get errors. AMP all works fine in the browser so i know its configured OK but the DW testing server won't work.

The AMP components all install to their default locations and my html files are in a desktop folder which the Httpd config file is pointing to.

Alternatively does the testing server only work if Apache maps to localhost which seems to me as though html files are mixed in with apache application files? What if i'm developing 2 sites. They cannot all mix together.

Unfortunately every tutorial only seems to deal with the document root as htdocs subfolder under apache. Then apache documentation says it can be anywhere.

Could anybody clear this up for me?

Thanks
mark


Ps I'm using Dreamweaver MX2004

davidj
07-27-2007, 09:04 PM
you using WAMP5 ?

codemangler
07-28-2007, 09:10 AM
Thanks for replying David and sorry for the late answer. Yes I am using Wamp5.

If its of any importance, there are no virtual servers set up in the http config file and no changes have been made to the hosts file. Live view returns the error message saying either the server isn't running / its not recognising php extensions or there's no scripts. Well the server is definitely running and there are scripts.

davidj
07-28-2007, 11:54 AM
just setup an alias

point it to a dir on your local machine. Call it webwork

anything inside webwork will then be processed by the php engine.

then just setup project directories inside webwork like project1, football, facebuk, mytube, superbank etc

now just point dreamweaver to one of those sub directories

codemangler
07-28-2007, 04:15 PM
OK. I've made the following adjustment to httpd config:

# Alias modification for mbnet
Alias /mbnet "C:/Documents and Settings/mark/Desktop/mysite.com/"
<Directory "C:/Documents and Settings/mark/Desktop/mysite.com/">
Options Indexes MultiViews
AllowOverride None
Order allow,deny
Allow from all
</Directory>
#END OF mbnet alias edits

and the following change to DW's URL Prefix:
URL prefix = http://mbnet/
and the testing server folder is still the Apache installation path ie C:\Program Files\Apache Software Foundation\Apache2.2

And it still doesn't work. Can you spot anything immediate with this that is wrong?

Cheers
MarkB

codemangler
07-28-2007, 04:23 PM
Some further information if its of use.

I' getting this error message

Http error 404 cannot find file http://mbnet/addnewuser_wee0lwafw.php which must be a temp file made by dreamweaver as tha actual file is the same name but without the _wee0lwafw bit.

Also http://mbnet now points to where localhost did before which i presume is correct.



The "C:\Program Files\Apache Software Foundation\Apache2.2" folder does not map to the Http://mbnet/ URL on the testing serve. Verify that the URL prefix maps to the root of your site.