View Full Version : Firefox not accepting my CSS

07-21-2007, 06:07 PM
First off, hello! Hopefully, I will learn something new from you all!

I am working on a site for a friend of over 10 years. I have pretty good understanding of HTML coding and CSS (even PHP) but this one has me utterly flabbergasted!

Here is the link to the soon to be site so far:

www.thethreemoirae.com/MoTeCEast/2.html (http://www.thethreemoirae.com/MoTeCEast/2.html) (a new way of laying things out)
www.thethreemoirae.com/MoTeCEast/index.html (http://www.thethreemoirae.com/MoTeCEast/index.html) (the way my friend saw it last)

Now, here is the problem (in firefox):


Now in netscape, the bottoms "best viewed" is time new roman!

In IE7, Opera, Safari....absolutely stunning! In firefox....EEEW!

I'm so confused and I can't seem to figure out why FireFox does not like my code!?

Please...I need some guidance before my head of hair becomes GRAY!

Many thanks in advance!

I'm using:

Web Developer Toolbar

Have you tried the Ctrl+ to fix the font..?

Yes, and it is still not working.

07-24-2007, 06:57 PM
Sorry, i don't see any diff in the second link between browsers. First link is a broken link

07-25-2007, 03:29 PM
sorry bout that, i removed it accidentally!

anyhow, it turns out that it isn't my css, it's the way firefox is? i've tried to make the font smaller in my view-text size-ctrl+- but it didn't do anything. I wonder if it is a firefox bug or is it that my web developer tools is disabling the css?

I've tested on other browsers and they look fine...however, this tiny irritation which I will post in another "topic"...


07-25-2007, 03:33 PM
Ya, I didn't see any difference either. The second link Kittyprrrs provided has smaller text than the image posted but it looks the same in both IE and FF, except in IE the background for the browser links is brown. Not a big fan of those though, most browser automatically update unless you set them up not to. A normal user would just let them auto update.

First link was broken for me as well.

07-25-2007, 03:43 PM
annoying thing is this..i played with dw4 for years. i just recently changed to dw8...i can't remember the simplest things (A normal user would just let them auto update.)....but the hard stuff...rollover/jump/close window on this action...blah blah...i remember but the simplest stuff i can't remember! Call it old age or just absent mindedness....caused by a 2 year old....dunno!?

isn't there a code to auto update/refresh page? i don't think I have it in my pages anywhere...

please advise:oops:*embarassed*

07-25-2007, 04:48 PM
There is code to auto refresh, but I am not sure why would you want to do that? I was simply saying that when someone buys a computer the browser that is preinstalled on it (usually Internet Explored) with automatically update itself whether the user wants it to or not. FireFox does this to by default. To keep it from doing that the users has to go into the options and uncheck auto update, which most users don't. So, I was saying that the logos for the Browser at the bottom of your home page and the text " Please visit the links below to download and install the latest version of your browser." is not necessary because most browsers already do that.

Unless the user is going for say, IE 6 to IE 7, but by then Microsoft has already bombarded the internet and their computer telling them to update.

hope I didn't confuse you more?

07-26-2007, 12:16 PM
no...no confusion at all. I hate that I had to code differently for IE6 (cause I like using png's...they look better {imo} than gif when it comes to filters in PS...like DROP SHADOW and Outer Glow's and I hate that if i want a smooth effect, I would have to save the image as a jpg with a background which when I import it, you can see the difference...I think you all know what I am talking about...?) So I asked the friends husband that I making this for, what he wanted....he said have everyone either upgrade to IE7 or Firefox.

So here is my question....WHY is my firefox not allowing me to reduce my font?

d a v e
07-26-2007, 06:08 PM
have you tried View > text size > decrease? rather than the shortcut keys?

07-26-2007, 11:36 PM
yes...tried them all...i wonder if it is my monitor that is causing the problem? it's a viewsonic wide screen?

d a v e
07-27-2007, 08:30 AM
do you have anything set form minimum font size in Tools > options > content : fonts and colours, advanced tab...