PDA

View Full Version : How do I insert a favicon?


minpot
07-09-2007, 11:43 PM
:confused: I'm not sure where to place my doubt:
Websites/Dreamweaver
html
photoshop

Since I'm not sure, I will place my doubt here and see where it goes . . . .
I want to do the favicon.ico. I know i need to download a plug-in for photoshop, I did. Then i need to add my image.ico file it to my root directory of my site,which i did/ Then I also placed it in the <head> of my index page as i was told to . . . .BUT nothing seems to be working in order to have it place in the browser window.
Anyone here knows what is it that i'm doing wrong?
Thanks for help and guidance

fwr1000
07-09-2007, 11:52 PM
What did you place in the head? It should be

<link rel="shortcut icon" href="/favicon.ico" type="image/x-icon" />

Fred

PS: If you are using Templates, be sure an place it in an non editable region of the head so it will carry to your child pages.

fwr1000
07-10-2007, 12:02 AM
Forgot one thing, the icon does not show up in IE6. Firefox, Opera, IE7 will all work. That's not just this method but just how IE6 works.

Fred

chriskq
07-10-2007, 01:57 AM
http://tools.dynamicdrive.com/favicon/

above is a online generator. creat the image, add the code fwr1000 mentioned, and drop the favicon in the root of your project folder (local and ftp)

favicons do work in IE6 btw.

fwr1000
07-10-2007, 02:09 AM
chriskq

Strange, I can't seem to get them to work in IE6. Maybe something on my laptop but it's the same for 4 different site I have done.
Fred

Cary
07-10-2007, 04:49 AM
IE6 will show the icons in the bookmarks, but not the address bar.

minpot
07-10-2007, 08:08 AM
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml"><!-- InstanceBegin template="/Templates/template_min_web.dwt" codeOutsideHTMLIsLocked="false" --><link rel="Shortcut Icon" href="/loguito_ico.ico" />
<head>

IS THE HTML CODE FOR MY .ICO IN THE CORRECT PLACE?

fwr1000
07-10-2007, 11:59 AM
You head section in the template should look like this

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
<!-- TemplateBeginEditable name="doctitle" -->
<title>Untitled Document</title>
<!-- TemplateEndEditable -->
<meta name="Description" content="the description of you site goes here" />
<link rel="shortcut icon" href="/favicon.ico" type="image/x-icon" />

</head>


Notice that the doctitle is within the editable tags so you can change each title on your child pages but the decsription tag is outside the editabalbe region so you can make it unique for each child page. The favicon is also outside the editable section so it will carry over to each page and all of the tags are between the <head> opening tag and </head> closing tag.

HTH
Fred

minpot
07-10-2007, 11:53 PM
Hey FWR1000 I inserted the code as you said, all seems right, I saved my template then all my child pages updated, then uploaded unto my server to publish and nothing . . . . . favicon.ico wont show :(
pls. visit my modest page do you can see
www.minervawebdesing.com (http://www.minervawebdesing.com)
thanks and pls. guide me some more . . . . a beginner needs a hand to continue

minpot
07-10-2007, 11:54 PM
sorry
www.minervawebdesign.com (http://www.minervawebdesign.com) a typo error sooooooooorry

fwr1000
07-11-2007, 12:15 AM
Here is the code from the header on your home page

<link rel="shortcut icon" href="/favicon.ico" type=image/loguito_ico.ico"/>

here is from one of my pages

<link rel="shortcut icon" href="/favicon.ico" type="image/x-icon" />

The difference seems to be in the type="image/ section. Not sure where the
loguito_ico.ico" came from. Only thing I can suggest is to use /x-icon instead.

Give it a try and see.

Fred

colaroid
04-06-2010, 03:54 PM
I am having the same problem. I have tried closing everything clearing the cache and viewing the webpage again in both firefox and IE. I have checked the code and there was no error message when I uploaded the icon file. It is in the directory with the index.html file.

On my page the html code seems correct. Did you fix your problem?:(

I posted a few minutes too soon. being a doughnut I had my pic named as faveicon (problem 1) after noticing this and correcting it the icon still wouldn't show. After uploading the newly renamed favicon file, I used ccleaner to clean my cache and temporary internet files after closing down dreamweaver/mozilla and the icon appeared on my next visit to my website-hurrah!