PDA

View Full Version : can't connect to localhost mysql database


diesel77
05-17-2007, 10:51 PM
Im using wamp server and want to connect to my database using dw 8.

my settings in dw are:

local info:

local root folder C:\wamp\www\folder\
default images folder C:\wamp\www\folder\images\
http address http://localhost/folder/

Remote info:

access local/network
remote folder C:\wamp\www\folder\

Testing server:

server model php/mysql
access local/network
testing server folder C:\wamp\www\folder\


MySQL connection

Mysql server localhost
username root

I click select database and get the following message

1) There is no testing server running on the server machine.
2) The testing server specified for this site does not map to the
http://localhost/folder/_mmServerScripts/MMHTTPDB.php URL. Verify that the URL prefix maps to the root of the site


when I type localhost into the browser everything is working fine, I just cant get dreamweaver to connect to my database.

davidj
05-17-2007, 11:04 PM
when you set up a site in dreamweaver there should have been a directory created called _mmServerScripts

Manually upload this or copy it to your live site.

also you have your live and local as the same dir! this will cause problems so separate these two directory's

diesel77
05-17-2007, 11:14 PM
I have the _mmServerScripts folder inside C:\wamp\www\folder\

is this right?

davidj
05-17-2007, 11:20 PM
yes

so now you need to have a seperate directory for local and remote

diesel77
05-17-2007, 11:28 PM
I changed the remote directory to C:\wamp\www\folder\remote\
I also tried C:\wamp\www\remote\

Im still getting the same message

1) There is no testing server running on the server machine.
2) The testing server specified for this site does not map to the
http://localhost/folder/_mmServerScripts/MMHTTPDB.php URL. Verify that the URL prefix maps to the root of the site

davidj
05-17-2007, 11:31 PM
and what is the name and path of the local dir

davidj
05-17-2007, 11:34 PM
do you have a firewall like zone alarm

if so switch it off

diesel77
05-17-2007, 11:52 PM
David, it actually seems to be the firewall. I cant belive it, Ive been at this thing all day. It never accured to me because it usually gives me an indication if its blocking something.

Thanks alot for your help.