PDA

View Full Version : My tables arn't showing correctly.


Andromeda
03-18-2007, 01:45 AM
Would some one please tell me why, in IE, my three tables appear side by side rather than under each other. See:
http://www.wtl.org.nz/constr/index.html

My css is as follows:

Body {font-family: Tahoma, Verdana, Arial; font-size: 10pt; color: #ff0000; background: url(../images/bround.gif);}


H1 {font-family: Tahoma, Verdana, Arial; font-size: 14pt; color: #0066aa;}

H2 {font-family: Tahoma, Verdana, Arial; font-size: 10pt; color: #0066aa; font-weight: bold;}

H3 {font-family: Tahoma, Verdana, Arial; font-size: 10pt; color: #0066aa; font-weight: bold; text-align: center;}

H4 {font-family: Tahoma, Verdana, Arial;
font-size: 10pt;
color: #0066aa;
font-weight: bold;
text-align: left;}

H5 {font-family: Tahoma, Verdana, Arial;
font-size: 10pt;
color: #FA9C85;
font-weight: bold;
text-align: left;
vertical-align: bottom;}

a:link { font-family: Tahoma, Verdana, Arial; font-size: 10pt; color: #0066aa; text-decoration:none;}
a:visited { font-family: Tahoma, Verdana, Arial; font-size: 10pt; color: #0066aa; text-decoration:none;}
a:hover { font-family: Tahoma, Verdana, Arial; font-size: 10pt; color: #0066aa; text-decoration:underline;}
a:active { font-family: Tahoma, Verdana, Arial; font-size: 10pt; color: #0066aa; text-decoration:none;}

table.tab001 {background:#FFFFFF; border-left:solid 8px #FF0000; border-right:solid 8px #FF0000; border-bottom:solid 8px #FF0000;}
table.tab002 {background:#FFFFFF; border-left:solid 8px #FF0000; border-right:solid 8px #FF0000; border-bottom:solid 8px #FF0000;}

Any takers????

Meeguk
03-18-2007, 01:51 AM
Do you have a mixture of layers and tables on your page?

Try Modify/Convert Tables to Layers or Layers to Tables. Do a save-as first. Maybe file1 file2.

Let me know.

Andromeda
03-18-2007, 02:05 AM
Thanks for the suggestion but I have no layers on my page.

lux
03-18-2007, 09:25 AM
we'll need to see your html

Andromeda
03-18-2007, 10:19 AM
It can be seen here.
http://www.wtl.org.nz/constr/index.html

domedia
03-18-2007, 11:31 AM
You actually set each of the tables to be aligned left. If you want no alignment, just remove it.

<table width="800" border="0" align="left" cellpadding="0" cellspacing="0">

Another tip: having a website set to 800px wide is not a good idea. You're really close to designing for an 800*600 resolution, but only have about 760 pixels available in the viewport of a browser, soo a width of 800 is going to give a horizontal scrollbar (not cool) in browsers maximized in 800*600.

Andromeda
03-18-2007, 07:33 PM
Breathes a HUGE sigh of relief. Thank you Domedia.
One wonders why Dreamweaver has the option if you don't need it???

Thanks for the 800px reminder - still playing around with that area - but the end product will not have a horizontal scroll bar (unless of course it's viewed in less than 800).

domedia
03-19-2007, 01:02 PM
Breathes a HUGE sigh of relief. Thank you Domedia. Anytime Andromeda :)
One wonders why Dreamweaver has the option if you don't need it??? You do need it in many occasions. The responsibility is on your shoulders; if you don't need it, then don't use it. ;)