PDA

View Full Version : SWF in Dreamweaver MX2004?


IronMonkey
02-06-2007, 03:40 PM
Hello Everyone!

Here's my problem.

I have exported a SWF file with a control bar from Flash 8 to embed in DMX2004.

I "inserted" the SWF into my HTML page. Then, when I "preview" in a browser it automatically starts and the control bar isn't viewable at all.

I unchecked the "Auto Play" and "Loop" boxes and it still starts when the page is loaded.

What's happening?

Is there a way that I can have the control bar viewable?

Also, does anyone have the parameters so the SWF will not autoplay when the page is loaded?


THX for your time and help!

IronMonkey

domedia
02-06-2007, 06:22 PM
Hello iron,
what control bar are you talking about? Can we see the actual code?

IronMonkey
02-06-2007, 06:38 PM
I'm at work right now, so I don't have the code.

When I imported the video into Flash 8, it gives a option to chose what type of "control bar" or "skin" to use, ie "PLAY/PAUSE, STOP, NEXT, etc.

I chose one that suited my taste.

It shows when the video is played through the Flash Player but not through the HTML page when I preview it.

I hope that helps a little.

THX

davidj
02-06-2007, 08:06 PM
does the flash output one file?

could it be that the control is a seperate swf which calls in the movie?

im guessing here

IronMonkey
02-06-2007, 08:45 PM
You know what!? I think it is!!!

But how do I includ that in DMX2004 to play along with the Flash movie?

THX

domedia
02-06-2007, 08:57 PM
If you export from Flash it should make all the files for you.

IronMonkey
02-06-2007, 09:03 PM
It did. When I place the SWF file it DMX and preview it the control bar doesn't show at all, just the movie.

davidj
02-06-2007, 10:02 PM
what other files do yo have when you exported the movie

please name them all

IronMonkey
02-06-2007, 10:24 PM
The "Movie file.swf" and a "SteeloverTrans.swf".

The second fill mentioned is the control bar. I remember the name when I was importing the video to make a SWF.

THX

davidj
02-06-2007, 10:32 PM
which file are you loading into your page??

IronMonkey
02-06-2007, 11:24 PM
I'm loading the movie file only.

So I'm guessing I have to load both files?

I didn't think I have too. MAN!

davidj
02-06-2007, 11:29 PM
try and load the other file first

that may call in your movie

domedia
02-07-2007, 12:06 AM
OK, so you're creating FLA files through the encoder that comes with flash 8... Read the instructions *carefully* when doing this. There's several items you need to look out for.The screen in the process called 'Finish Video Import' gives you detailed information.

IronMonkey
02-08-2007, 06:46 PM
Well! It was the .FLV file that need to be loaded not the .swf!

It's working now!

THX for your help.

Pe@ce