PDA

View Full Version : Flash of white with iframe


Ricky55
02-03-2007, 06:06 PM
Don't know if this happens in ie 6 but it definielty does in ie7, when my page first loads content into my iframe the area of the iframe flashes white just for a split second and then the content loads. Any subsequent content is then loaded ok and this problem seems to stop.

Ever seen this?

Does anyone know how to fix it?

Its not then end of thw world but it is quite annoying especially on the site that I'm currently working on as the background is black.

Thanks in advance.

Ricky55

davidj
02-03-2007, 06:45 PM
this is normal as there is a delay while loading content

you could load a blank page with the chosen colour then from that page preload the flash file then check its loaded before doing a refresh to the new flash ready page..

dont know if this will work but its worth ago

this may be a delay from the tmp dir to the browser and therefore its normal

Ricky55
02-03-2007, 07:39 PM
Thanks.

It doesn't actually appear to have anything to do with the colour of the file that I'm loading in as my site is black with a black back ground and the file I'm loading in is also black.

If anyone else as any ideas?

Ricky55

davidj
02-03-2007, 07:48 PM
yes but try and load a blank page with no flash

to see if you get that initial white flash

you may be able to load flash using ajax... Mmm that may work

domedia
02-03-2007, 09:58 PM
Ricky, if you're not loading external content from another website, using an iframe seems a little redundant. The default browser background is going to show until the browser gets content to render, there's no fix for this, it is the expected behavior.

Ricky55
02-04-2007, 10:49 AM
ok thanks for trying.

sagarvwagh
03-31-2012, 02:39 PM
Here I find a good solution that is working. Do try it:
http://swsharinginfo.blogspot.com/2011/11/avoid-iframe-white-flash-issue-while.html