PDA

View Full Version : Concerning versions


michael_9992
12-04-2006, 06:15 AM
Hey, I've been watching the sites video tutorials, and I am running wamp v 1.6.6
These are the versions of the programs:
Apache 2.0.59
PHP 5.2.0
MySQL 5.0.27

I run my website using cpanel, and these are their versions:
PHP version 4.4.4
MySQL version 4.1.21-standard
Apache version 1.3.37 (Unix)

Do i need to download a different version of wamp so it's version are the same if not below the ones that cpanel says?

davidj
12-04-2006, 06:28 AM
i would contact your host and ask them when are they going to upgrade their products

you should be ok as long as when you write some code make sure the older version of PHP supports it.

you may have to visit http://www.php.net/ to confirm you dont have any conflicts with your code but i reckon that in the early stages of learning then your not going to encounter any problems. Your better off using php 5 as its easier to change your host to a one that supports the latest versions

michael_9992
12-04-2006, 06:53 AM
ok, thanks, so where on the php site would i go to check?

michael_9992
12-04-2006, 06:54 AM
also, should i learn html before php, and is there anything else I should learn? Cause id rather go step by step, like work from say html to advanced stuff

davidj
12-04-2006, 07:23 AM
Yes you need a good understanding of HTML

you need to learn to walk before you can run

michael_9992
12-04-2006, 07:43 AM
ok, thanks. I have already started learn html off this good site, www.html.com. lol, the url explains it all, but its really good.