View Full Version : Special characters; questions marks in text

08-15-2006, 04:51 PM
On only one of my websites, I have a problem with special characters. It's a monthly magazine web site www.insidetennis.com. This problem has been going on for many issues. I seem to have it figured out. But every month, it crops up again and I go mad trying to find a reliable solution.

Sometimes I have unwanted question marks or unwanted characters when seen in a broswer. Sometimes I can't type correctly into the type whether it be in DW design or code mode.

The problem seems to stem for this: I strip the text out of Quark. This text has these special characters that the html coding doesn't like:

I've searched and replaced the special characters out of the file. Usually that works, but not always.

The page I have up now: www.insidetennis.com/0906_first_serve.html shows question marks at points in the text where I have started new blocks of text.

I have experimented with the Page Properties/Title/Encoding. The following meta tags are supposed to clean this up. However, sometimes they work and sometimes they don't.
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">

Any help would be greatly appreciated.

08-15-2006, 04:58 PM
UTF-8, which you've got now, is the answer :)

08-15-2006, 05:11 PM
I believe you but

Go take a look at www.insidetennis.com/0906_first_serve.html

I see two questions marks that are not in the text: Right below the vertical photo on the top left and in the pullquote in the bottom right.

08-15-2006, 05:15 PM
I see the problem in IE and Firefox on a Mac but not in Safari

08-15-2006, 06:57 PM
Looks fine here in all browsers.

08-15-2006, 08:00 PM
What setting do you recommend for Unicode: C, D, KC or KD> Should I include the Unicode signature (BOM)?

When I go into Firefox and IE and view the source code, I can see the two question marks. In Dreamweaver design and code views, the cursor jumps around the first word after the question mark. There's some hidden item that is causing the problem. But I can't get to it.

Thanks again

08-15-2006, 08:59 PM
With a little creative backspacing, I was able to delete the hidden character.