PDA

View Full Version : Hyperlink problems


rebootuk
05-27-2006, 05:17 PM
Hi, I have 2 domain names running with 1 host so this may have something to do with my problem which is this. I am trying to make a link in text form to my other domain site but when I upload, the link includes the website I am editing plus the web site I am linking to. Can anyone tell me why and perhaps how to fix it. Here is the sample. If you visit

www.kevkelly.net

the link will have this

http://www.kevkelly.net/www.klean-kut-gardeners.co.uk

The last obviously being my other domain.
Thanks for looking
Kev

dthomsen8
06-01-2006, 11:07 AM
Hi, I have 2 domain names running with 1 host so this may have something to do with my problem which is this. I am trying to make a link in text form to my other domain site but when I upload, the link includes the website I am editing plus the web site I am linking to. Can anyone tell me why and perhaps how to fix it. Here is the sample. If you visit

www.kevkelly.net

the link will have this

http://www.kevkelly.net/www.klean-kut-gardeners.co.uk

The last obviously being my other domain.
Thanks for looking
Kev

I suspect that the problem you state above is caused by how you have defined your sites in Dreamweaver's Site Manager. You should have two defined sites, one for the pub, and one for the gardeners, and you should be uploading to two distinct domain names.

There are so many other problems, though, that I hardly know where to begin. At the minimum, use a DOCTYPE and a language specification on every page, and then learn how to do HTML validation at www.w3.org for the results. It is hopeless to try validation without the DOCTYPE, though.

I wonder why Dreamweaver isn't providing the DOCTYPE and language specifications as defaults in creating a basic page. Create a basic page and look at the HTML, and probably you will see what you need.

What version of Dreamweaver are you using? Have you created web pages in DW, or are you using an existing site and working with DW?