PDA

View Full Version : CSS navigation/preview


qwerty007
03-31-2006, 08:41 PM
I've been putting a site together using CSS which works fine in Dreamweaver and browser. However once you start to navigate around the site, the pages start to appear unformatted by the styles. All pages are linked to an external .css file and reside inside the site folder. The browser creates a temp folder each time you preview the pages, but when using the navigation it takes you back to the original pages. Does this mean that a siteusing CSS has to be uploaded before it will work properly?

Creative Insanity
03-31-2006, 10:26 PM
No.. show us something, my crystal ball is a litte merky today. :p

qwerty007
03-31-2006, 11:35 PM
Give it a clean then ...what's the matter ...can't read?

d a v e
04-03-2006, 04:02 PM
a url would be polite ;)

qwerty007
04-03-2006, 06:05 PM
Helpful maybe, polite I'm not so sure, but perhaps my crystal ball needs polishung too. :wink:

Simply, there is no link, this is all happening on my hard disc.

d a v e
04-03-2006, 06:43 PM
:)
have you tried previewing without using a temporary file (ctrl+u or general options and preview) ? also have you checked that the stylesheet is linked and has the correct relative path (you could run the check links in the site window on the right)

qwerty007
04-03-2006, 07:55 PM
Problem fixed! It wasn't the temp file, but relative linking (I think). The files had been downloaded and I wasn't sure what had been done to them, but with all links, including the links to external css relative to the document and not the site root it seems to work. The site folder name also may have been at fault, since I has added a full cap on the beginning of one of them by mistake.

Well spotted Dave!!! Thank you :lol: