PDA

View Full Version : MySql user


pikespeakwebsolutions
03-16-2006, 04:28 AM
As far as i understand you should not use @localhost when you go online. So here is the sql i have written to create a user that should work
[GRANT all *.* TO
dbuser@mySite.myDomain.com IDENTIFIED BY "myPassword";]
then i go into dreamweaver and here are the settings i use
Remote Info:
* Access: FTP
* FTP Host: myhost.com
* Host Directory: /htdocs/
* Login: webadmin
* Password: *********

Testing Server:
* Server Model: PHP / MySQL
* Access: FTP
* FTP Host: myDomain.com
* Host Directory: /htdocs/
* Login: webadmin
* Password: *********
* URL Prefix: http://myDomain.com

MySql Connection Name: choose a name (e.g. ccalls)
MySQL Server: mysql1.myDomain.com
User Name: dbuser
Password: myPassword
then when i select database i get different errors after trying to connect for a few minutes

Tell me what part in the set up im doing wrong thanks alot


[/code]

Creative Insanity
03-16-2006, 07:41 AM
The host directory is incorrect.
Host Directory: /htdocs/
Is not correct.
It should read like:
/home/username/public_html/
If you are hosting on a win server check with the hoster as win hosting has a number of options that differ from Linux hosting. What I say above deals with Linux hosting.

ramandeep
03-16-2006, 08:31 AM
CI, hostdirectory differs depending upon the hosting server
It can be HTDOCS, HTTPDOCS, PUBLIC_HTML etc..

According to me
As you are using your webserver as your testing server , then try giving MySQL server in your database connection as "localhost"

I am assuming that you get connected to your testing server successfully and then you are making a database connection.