PDA

View Full Version : How to get rid of Active X


chriskq
03-06-2006, 01:32 AM
hello all,
just experimenting playing around with alot of javascripts. I have gotten one i like to work, but when i load the page in IE it gives the security Active X control msg... is there any way to get around this?
(as i notice only some javascripts will make the Active X msg appear.)
I got the script from here:
http://javascript.internet.com/time-date/digital-clock.html

Soad
03-06-2006, 04:29 AM
You can turn it off in tools,internet options,advanced and scroll down to security and check the active boxes.

Creative Insanity
03-06-2006, 05:20 AM
In tools select internet options, select security and then click the modify button. You will find all the activeX options that the warning refers to in there.

chriskq
03-06-2006, 05:55 AM
Oh well i knew that (like options for my computer) - but wat about the target audience of my page.... i dont want them to have to change any of their internet settings (ALL for a tiny javascript that makes text scroll across the page)
is there another way to get around it.... like the script that im using obviously isnt harmful to the computer, so why does it think it is?

http://www.javascriptkit.com/script/script2/highlight2.shtml

When u view it from the page where i got it from - It doesnt ask me to turn on active X... so why does it do it from my local?

plllssssssssss help this is frustrating.. ger** C'arn DJ share the wealth.

chriskq
03-07-2006, 12:23 AM
i thought maybe saving the page as a different extension might work. At the moment i have .html. Would using .xhtml (strict) change anything or s.html
any ideas pls say

domedia
03-07-2006, 02:35 AM
You can't change the users security settings.. that would be a major flaw in their software..
But hey, it's IE, so you never know ;) there might be someone that can help you!

chriskq
03-07-2006, 04:38 AM
i understand that u cant change users internet settings.... (my god if u cud, all our harddrives would be corrupted in sitting in a garbage heap somewhere)
but my Question is this:
How does the page where the script is found not get that active x control msg at the start (the one i get when i open my site in IE from my local)
help...

chriskq
03-08-2006, 11:43 PM
just wondering if anyone knew if teh extension of your webpage effects how ur broswers views active x. Havnt had any luck trying to get that active x msg not to appear in IE. (it is possible though)
thought id post again in case someone didnt c.

Bud
04-25-2009, 09:37 AM
I'm also very interested to find a cure for this.

Obviously I don't want the 'active x' prompt to show for everyone who visits my site simply becaue it has a rollover image.

Any ideas?

Thanks

(PS. may be a slightly different answer as I'm using the Image Objects>Rollover Image function is CS4)

Bud
04-25-2009, 10:27 AM
Possibly answered my own part of the problem...

After further investigation found the answer elsewhere in the forum. Still get the active x prompt in my own previews (which can be sorted if required), BUT when the site is uploaded and live there is no problem for users.

Not sure if that helps chriskq?

Cary
04-25-2009, 07:28 PM
For local testing you can use the menu Commands > Insert Mark of the Web.

This adds a special comment after the doctype and before the opening html tag. It basically tells IE that it's okay to allow activex. If you look at the Commands menu you'll see it has changed to allow you to Remove the Mark of the Web cemment, or you can just delete it from code view.