PDA

View Full Version : Problems with alignment of table and layer


theselfp
02-28-2006, 11:51 PM
Hello everyone. I am having problem on my current project.
http://www.indiefilmmakerswarehouse.com/3.html
When it is viewed in DW MX2004 It looks like crap, however in IE 5.0 it looks right. Does anyone know why and how I can make it look right in both? In DW my tables are way out of alignment, and my Menu (on a layer) is high, not on the base line of the table.

Also, on another site I am tring to build it looks perfect in IE 5.0, but all other Browsers view it in other ways, that make it a nightmare on the eyes and to use. Is there anyway to make the HTML read universaly? If anyone can help me on either problem, I'd greatly appreciate it. I have no experience with building sites other than just trial and error with DW, so any help will be better than what I know. Thanks alot in advance.

Shaun

Creative Insanity
03-01-2006, 12:45 AM
Looks fineish in FF 1.5 and IE6, but I would set the left and top margins to 0

domedia
03-01-2006, 02:50 PM
Making it look good in DW usually means nothing of how it will look in different browsers. DW is not a browser and uses a different rendering engine that FF, IE etc.

Hiya Shaun,
The only way to solve this is to read up on HTML and browser differences. You can't simply make something in DW and expect it to look good in browsers. If someone told you it was that easy, you've gotten the wrong advice :-(

If you've never built websites before, this will take some time. There's thousands of pages online talking about browser differences (Google is your friend ;)) and it's not plug-and-play, sometimes it can be really hard to make things look the same cross-browser, even for those of us that has done it professionaly for years.

I would like to suggest that you learn how to write your own HTML and CSS first, but maybe someone else has better advice.. 8)