PDA

View Full Version : Live Data view & the Disappearing DataSet


jsabarese
07-18-2005, 01:40 AM
According to several users who want to use ASP.NET as a server side scripting language for web applications seeking help in Dreamweaver support forums, a common problem occurs when a database connection is established using the "+" in the Database tab of Dreamweaver's Application window. These users experiencing the problem, myself included, meet a seemingly insurmountable obstacle of the Database tables NOT showing in the Database tab of the Application window after the connection has been made. In particular, this problem reportedly occurs only for Windows XP SP2 users.

i discovered this issue while working through the tutorial on pages 101 and subsequently pages 68-73 of the DW_Getting_Started.pdf, a tutorial which DW owners should find included in the Dreamweaver documentation.

There are several resources and suggested fixes available which offer possible workarounds to solve this disappearing database table problem-- one being to install a Dreamweaver Extension, the "SP2 DB Fix" available here http://www.macromedia.com/cfusion/knowledg...cfm?id=tn_19515 ('http://www.macromedia.com/cfusion/knowledgebase/index.cfm?id=tn_19515')

I've read some reports which suggest that this fix doesn't solve their problem, however it did work for me.

Now that i've been able to establish the database connection, and add the Recordset (or DataSet as it is named by ASP.NET), I've encountered another problem. Proceeding through the same tutorial, as instructed, I inserted items from the Recordset into the aspx page, and then applied repeat region in order display more than one record called from the recordset. This being the final procedure for this aspx page, to demonstrate that all of the steps have been followed correctly up to this point, and to display the dynamic data being pulled from the recordset created, the tutorial then instructed me to enable DW's "Live Data" view. When i select View > Live Data (or press the Live Data button near the Code/Split/ Design view buttons) the Recordset (DataSet) disappers from the Bindings tab in the Application window! If i deselect Live Data, the Recordset returns.

I tried previewing in the Browser, but instead of a preview as with a static html page, IE prompts me to open or save the file. If i select "open", the file is then opened in Dreamweaver, and all of the images are missing due to broken links-- as if the folder structure / relative paths are not correct. however, if i select the same file from Remote View in the DW Files window, all of the images are shown.

Does anyone know if my problem is yet another DW / SP2 / ASP.NET glitch, as was the case w/ the invisible db tables, or could this possibly be a result of an error in my DW Local/Remote Site setup?

I have had much more success w/ ColdFusion, that's for certain! I'm not giving up on ASP.NET yet. I'm confident that someone has the answer to solve this problem. I'll be anxiosly awaiting your reply to save me from this frustration!

ranjan
07-18-2005, 02:56 PM
In your preferences do u have "preview using temporary files" checked or unchecked

Have you made sure that aspx is a recognizable file extension in your IIS setup?