PDA

View Full Version : Perplexing html Formail error


warrior
07-05-2005, 02:37 PM
I have this relatively small but very annoying problem that I can't solve despite staring at my code for days.

I created 3 rather detailed registration pages for a clients site using the standard Formmail.pl script supplied by the webhost. ( The script configuration FAQ can be found at http://www.scriptarchive.com/) ('http://www.scriptarchive.com/)')

To display the registration type in the subject header in the resulting email I used the line
<input type=hidden name="subject" value="my form name">. Simple, should work.....the results my client is getting however is saying 'No subject given'?

EXCEPT when I submit a dummy form from my machine ( Mac OSX.3.9), the form result works perfectly..... She is using Windows XP, and going on the list of problem form result emails she's forwarded to me - all are from Windows users.

Although I can't see how such a simple script and request can be affected by platform.

I even tried removing the subject input code entirely in the hope that the default subject header would appear in her email result (www form submission) as it is supposed to. (see FAQ URL above) However even this didn't work.

You can find one of the forms at the URL below.

http://www.aupairaustralia.com.au/index8.html ('http://www.aupairaustralia.com.au/index8.html')

If anyone has the inclination please have a look at the code and see if you can see something I can't - I'd be very appreciative.... Or of course someone may have had a similiar prob, I'd be glad to hear from you....