PDA

View Full Version : Uploading problems


SJCH
04-26-2005, 01:38 PM
I keep getting a message "Dreamweaver cannot determine the remote server time. The select Newer and Synchronze commands will not be available". and then I get the message "An FTP error occurred - cannot put index.htm. Access Denied. The file may not exist, or there could be a permission problem".

This is the first website I have built (I can hear your sighs from here) so any replies should be explained as if you were talking to a 4 year old. But please don't let that put you off as I will be eternally grateful.

I had phoned my webhost/server helpline, but after queueing for 20 minutes the only advice the spotty teenager could give me was to "Do a search on Google for Dreamweaver server time problems"! Which is how I stumbled on to this website, which is by far the most friendly and knowledgable I have come across.

I have been struggling with this problem for a couple of days now and as this is for my company's new website my boss is getting a little impatient.

3 years ago a webdesigner designed and uploaded a website to the location I am trying to upload to (which never worked either, although i'm not sure if he had the same problem). So all I want to do is update his website for mine

I have read that many people are having the same problem but nobody seems to be able to give an answer for Mac users.


Please Help
SJCH

gmcrone
04-26-2005, 03:14 PM
First lets answer WHY it is happening. This can be explained by 2 reasons:

1. There is a bug in Serv_U FTP 4 server that will convert all uploaded files and folders to lowercase whether you want them to be or not. Not your fault, it just happens.

2. When DW connects to the FTP server it creates a folder called XYIZNWSK gets the Date and time then removes it. You can see this in your FTP Logs as MKD XYIZNWSK and RMD XYIZNWSK. Notice the CAPS?

So here is the problem. DW attempts to write the folder in CAPS, Serv_U converts it to lowercase, DW attempts to read the Date time from a folder the file system on the remote server which doesn't exist. If you look on the remote view in DW you will see the XYIZNWSK in lowercase. When you click on it to view or remove the folder you get an error saying no such folder exists. Confused? Well thats about as difficult as it gets.

Now lets look at how we can fix it.

This turned out to be quite simple.

1. Go to your DWMX installation folder. (eg. C:\program files\Macromedia\Dreamweaver MX\) and backup your dreamweaver.exe file.

2. Now open the dreamweaver.exe file in a HEX editor such as the one here http://www.hhdsoftware.com/ ('http://www.hhdsoftware.com/') and search for XYIZNWSK.

3. Once you have located the UPPERCASE XYIZNWSK just replace it with a lowercase xyiznwsk by carefully typing it in and SAVE the file.

4. Open DW and connect to your remote server and you are back in business.

If you have any probs just copy your backup of the dreamweaver.exe file back to the directory and all is sweet.
Dont be too shy about making the changes. It isn't that difficult if you are careful and we have every faith in you.

Mike...

gmcrone
04-26-2005, 03:25 PM
OR, if you don't want to mess with your exe file.

Download an FTP program and upload your site outside of dreamweaver.

Do a google search for mac free ftp programs and you should have a few to try out

Mike...

Jim_Shady
04-26-2005, 03:34 PM
Bloody good reply that grcrone....

Will wait and see if it works for him!

Jim S.

ranjan
04-26-2005, 06:58 PM
Mike would it not be better if you had just linked to

http://dmxzone.com/showDetail.asp?TypeId=2&NewsId=3763 ('http://dmxzone.com/showDetail.asp?TypeId=2&NewsId=3763')

instead of doing a copy and paste?

SJCH
04-27-2005, 08:10 AM
Hi guys, thanks for the quick replys.

When I connect to the remote server I can see the 3 year old website, although the top folder is just called " / " There are 3 folders inside this.
The first is called "Docs" - which contains all the gifs and HTM page.

The second is called "ftp" which contains 3 folders "bin","etc" and "pub" none of which will open.

The third folder is called "logs" which will not open.

Because i'm working from a mac I wont have a "Dreamweaver.EXE" file.

I have tried the "dmxzone" link and found another mac user having identical problems - he says he contacted his webhost and they told him that dreamweaver MX 2004 was not compatible with their FTP system! surely this can't be possible.

Any thoughts?
SJCH

ranjan
04-27-2005, 09:27 AM
your host may have to follow the steps in this link to make FTP feature work

http://www.rhinosoft.com/kbsearch.asp?prod=su&ref=1368 ('http://www.rhinosoft.com/kbsearch.asp?prod=su&ref=1368')

But before you ask your host to do the above make sure you have exhausted the following troubleshooting at your end

http://www.macromedia.com/cfusion/knowledg...cfm?id=tn_14834 ('http://www.macromedia.com/cfusion/knowledgebase/index.cfm?id=tn_14834')